summaryrefslogtreecommitdiff
path: root/sci-geosciences/geopy/geopy-2.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-22 14:28:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-22 14:28:15 +0000
commitaae71b4d8e684ca22d28ef0f1da0989e7bf6468d (patch)
tree0e9cf35d85726e6aa9fbd58b12035f92ffec0130 /sci-geosciences/geopy/geopy-2.3.0-r1.ebuild
parent20ed81714fa97f5845db16a3c142b3b44d820bc4 (diff)
gentoo auto-resync : 22:02:2023 - 14:28:15
Diffstat (limited to 'sci-geosciences/geopy/geopy-2.3.0-r1.ebuild')
-rw-r--r--sci-geosciences/geopy/geopy-2.3.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-geosciences/geopy/geopy-2.3.0-r1.ebuild b/sci-geosciences/geopy/geopy-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..9fd7a2b8e4b8
--- /dev/null
+++ b/sci-geosciences/geopy/geopy-2.3.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for several popular geocoding web services"
+HOMEPAGE="https://github.com/geopy/geopy"
+SRC_URI="https://github.com/geopy/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# Need geocoding service to test
+RESTRICT="test"
+
+RDEPEND=">=sci-geosciences/GeographicLib-1.51-r1[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""