summaryrefslogtreecommitdiff
path: root/sci-geosciences/geocode-glib/geocode-glib-3.24.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-geosciences/geocode-glib/geocode-glib-3.24.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-geosciences/geocode-glib/geocode-glib-3.24.0.ebuild')
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.24.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.24.0.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.24.0.ebuild
new file mode 100644
index 000000000000..d2a1d05bf0f5
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.24.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GLib geocoding library that uses the Yahoo! Place Finder service"
+HOMEPAGE="https://git.gnome.org/browse/geocode-glib"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ gnome-base/gvfs[http]
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+
+# FIXME: need network #424719, recheck
+# need various locales to be present
+RESTRICT="test"
+
+src_configure() {
+ gnome2_src_configure $(use_enable introspection)
+}
+
+src_test() {
+ export GVFS_DISABLE_FUSE=1
+ export GIO_USE_VFS=gvfs
+ ewarn "Tests require network access to http://where.yahooapis.com"
+ dbus-launch emake check || die "tests failed"
+}