summaryrefslogtreecommitdiff
path: root/sci-geosciences/gdal-grass/gdal-grass-2.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /sci-geosciences/gdal-grass/gdal-grass-2.1.3.ebuild
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'sci-geosciences/gdal-grass/gdal-grass-2.1.3.ebuild')
-rw-r--r--sci-geosciences/gdal-grass/gdal-grass-2.1.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-geosciences/gdal-grass/gdal-grass-2.1.3.ebuild b/sci-geosciences/gdal-grass/gdal-grass-2.1.3.ebuild
new file mode 100644
index 000000000000..745a05ffcfa8
--- /dev/null
+++ b/sci-geosciences/gdal-grass/gdal-grass-2.1.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GDAL plugin to access GRASS data"
+HOMEPAGE="https://www.gdal.org/"
+SRC_URI="https://download.osgeo.org/gdal/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="postgres"
+RDEPEND="
+ >=sci-libs/gdal-2.0.0:=
+ sci-geosciences/grass:=
+"
+DEPEND="${RDEPEND}
+ postgres? ( dev-db/postgresql )"
+
+# these drivers are copied at install from the already installed GRASS
+QA_PREBUILT="/usr/share/gdal/grass/driver/db/*"
+
+src_prepare() {
+ sed -e 's:mkdir ${GRASSTABLES_DIR}$:mkdir -p ${GRASSTABLES_DIR}:' \
+ -i Makefile.in || die
+ default
+}
+
+src_configure() {
+ local grassp=$(best_version sci-geosciences/grass)
+ local grasspv=$(echo ${grassp/%-r[0-9]*/} | rev | cut -d - -f 1 | rev)
+ local grasspm=$(ver_cut 1-2 ${grasspv})
+ local myeconfargs=(
+ --with-grass="/usr/$(get_libdir)/grass$(ver_rs 1 '' ${grasspm})"
+ --with-gdal="/usr/bin/gdal-config"
+ $(use_with postgres postgres-includes "/usr/include/postgresql")
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ #pass the right variables to 'make install' to prevent a sandbox access violation
+ emake DESTDIR="${D}" \
+ GRASSTABLES_DIR="${D}$(gdal-config --prefix)/share/gdal/grass" \
+ AUTOLOAD_DIR="${D}/usr/$(get_libdir)/gdalplugins" \
+ install
+}