summaryrefslogtreecommitdiff
path: root/sci-geosciences/congen/congen-1.6.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-geosciences/congen/congen-1.6.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-geosciences/congen/congen-1.6.2-r1.ebuild')
-rw-r--r--sci-geosciences/congen/congen-1.6.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-geosciences/congen/congen-1.6.2-r1.ebuild b/sci-geosciences/congen/congen-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..23c270b570a5
--- /dev/null
+++ b/sci-geosciences/congen/congen-1.6.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+MY_P=${P/_p/-r}
+DESCRIPTION="Calculate speeds, equilibrium arguments, node factors of tidal constituents"
+HOMEPAGE="http://www.flaterco.com/xtide/files.html"
+SRC_URI="ftp://ftp.flaterco.com/xtide/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sci-geosciences/libtcd-2.2.3"
+RDEPEND="${DEPEND}"
+
+MAKEOPTS+=" -j1"
+
+S=${WORKDIR}/${P%_p*}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}