summaryrefslogtreecommitdiff
path: root/sci-electronics/xcircuit/xcircuit-3.9.73.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /sci-electronics/xcircuit/xcircuit-3.9.73.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'sci-electronics/xcircuit/xcircuit-3.9.73.ebuild')
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.9.73.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-electronics/xcircuit/xcircuit-3.9.73.ebuild b/sci-electronics/xcircuit/xcircuit-3.9.73.ebuild
new file mode 100644
index 000000000000..48d29c176683
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.9.73.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Circuit drawing and schematic capture program"
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="tcl"
+
+DEPEND="
+ app-text/ghostscript-gpl
+ media-libs/fontconfig:1.0=
+ sys-libs/zlib:=
+ x11-libs/cairo
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt
+ tcl? (
+ dev-lang/tcl:0=
+ dev-lang/tk:0=
+ )
+"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-cairo
+ --with-ngspice
+ $(use_with tcl)
+ $(use_with tcl tcllibs "/usr/$(get_libdir)")
+ $(use_with tcl tk)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}