summaryrefslogtreecommitdiff
path: root/sci-electronics/systemc/systemc-2.3.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sci-electronics/systemc/systemc-2.3.4-r1.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sci-electronics/systemc/systemc-2.3.4-r1.ebuild')
-rw-r--r--sci-electronics/systemc/systemc-2.3.4-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-electronics/systemc/systemc-2.3.4-r1.ebuild b/sci-electronics/systemc/systemc-2.3.4-r1.ebuild
new file mode 100644
index 000000000000..4669cd8f6d9b
--- /dev/null
+++ b/sci-electronics/systemc/systemc-2.3.4-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV}_pub_rev_20190614"
+
+inherit autotools
+
+DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
+HOMEPAGE="
+ https://accellera.org/community/systemc
+ https://github.com/accellera-official/systemc
+"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/accellera-official/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/accellera-official/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="debug doc examples static-libs test"
+REQUIRED_USE="examples? ( doc )"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ eautoconf --force
+}
+
+src_configure() {
+ econf CXX=$(tc-getCXX) \
+ $(use_enable debug) \
+ $(use_enable static-libs static) \
+ --with-unix-layout
+}
+
+src_install() {
+ default
+ if use doc; then
+ if use examples; then
+ docompress -x /usr/share/doc/"${PF}"/examples
+ else
+ rm -r "${ED}"/usr/share/doc/"${PF}"/examples || die
+ fi
+ else
+ rm -r "${ED}"/usr/share/doc/"${PF}" || die
+ fi
+}