summaryrefslogtreecommitdiff
path: root/sci-electronics/systemc/systemc-2.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-electronics/systemc/systemc-2.3.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-electronics/systemc/systemc-2.3.0-r1.ebuild')
-rw-r--r--sci-electronics/systemc/systemc-2.3.0-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/sci-electronics/systemc/systemc-2.3.0-r1.ebuild b/sci-electronics/systemc/systemc-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..0807538938a2
--- /dev/null
+++ b/sci-electronics/systemc/systemc-2.3.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs autotools-utils
+MY_P="${P}a"
+
+DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
+HOMEPAGE="http://accellera.org/community/systemc"
+SRC_URI="http://accellera.org/images/downloads/standards/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="doc static-libs"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="test"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # drop compiler check to enable use of CXX
+ epatch "${FILESDIR}"/${P}-config.patch
+
+ sed -i -e "s:OPT_CXXFLAGS=\"-O3\":OPT_CXXFLAGS=\"\":g" configure.in || die "Patching configure.in failed"
+
+ sed -i -e "s:lib-\$(TARGET_ARCH):$(get_libdir):g" $(find . -name Makefile.am) || die "Patching Makefile.am failed"
+
+ # respect DESTDIR
+ sed -i -e "s:\$(prefix):\$(DESTDIR)\$(prefix):g" $(find . -name Makefile.am) || die "Patching Makefile.am failed"
+
+ eautoreconf
+
+ sed -i -e "s:\$(DESTDIR)\$(libdir):\$(libdir):g" src/sysc/Makefile.in || die
+
+ for sfile in src/sysc/qt/md/*.s ; do
+ sed -i -e '$a \
+#if defined(__linux__) && defined(__ELF__) \
+.section .note.GNU-stack,"",%progbits \
+#endif' "${sfile}" || die "Patching ${sfile} failed"
+ done
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) CXX=$(tc-getCXX)
+}
+
+src_compile() {
+ cd src
+ default
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog INSTALL NEWS README RELEASENOTES
+ use doc && dodoc -r docs/*
+ cd src
+ autotools-utils_src_install
+}
+
+pkg_postinst() {
+ elog "If you want to run the examples, you need to :"
+ elog " tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
+ elog " cd ${MY_P}"
+ elog " find examples -name 'Makefile.*' -exec sed -i -e 's/-lm/-lm -lpthread/' '{}' \;"
+ elog " ./configure"
+ elog " cd examples"
+ elog " make check"
+}