summaryrefslogtreecommitdiff
path: root/sci-electronics/osqoop/osqoop-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-electronics/osqoop/osqoop-1.1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-electronics/osqoop/osqoop-1.1.1.ebuild')
-rw-r--r--sci-electronics/osqoop/osqoop-1.1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-electronics/osqoop/osqoop-1.1.1.ebuild b/sci-electronics/osqoop/osqoop-1.1.1.ebuild
new file mode 100644
index 000000000000..ef02a5592c6f
--- /dev/null
+++ b/sci-electronics/osqoop/osqoop-1.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="multi-platform open source software oscilloscope based on Qt 4"
+HOMEPAGE="http://gitorious.org/osqoop/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtgui:4
+ virtual/libusb:0
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-${PN}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ for f in $(find datasource processing -name CMakeLists.txt); do
+ sed -e '/install(TARGETS/s:DESTINATION :DESTINATION '$(get_libdir)/${PN}'/:' \
+ -i "${f}" || die
+ done
+ sed -e '/install(TARGETS/s:DESTINATION .:DESTINATION bin:' \
+ -i src/CMakeLists.txt helper/CMakeLists.txt || die
+
+ sed -e '/potentialDirs/s:/usr/share/osqoop/:'${EPREFIX}'/usr/'$(get_libdir)/${PN}'/:' \
+ -i src/OscilloscopeWindow.cpp || die
+}