summaryrefslogtreecommitdiff
path: root/sci-electronics/ngspice/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-28 04:06:07 +0000
commitccf84bcd604130256d1377cd58f0a634ae6ee20f (patch)
treef42a709e0c7805183f5680883bc76dc935b7a0cc /sci-electronics/ngspice/files
parentc85a90f90521c7e11d618b527d6630cc64cecbd4 (diff)
gentoo resync : 28.12.2017
Diffstat (limited to 'sci-electronics/ngspice/files')
-rw-r--r--sci-electronics/ngspice/files/ngspice-27-autoconf_fftw3.patch26
-rw-r--r--sci-electronics/ngspice/files/ngspice-27-split_terminfo.patch20
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-electronics/ngspice/files/ngspice-27-autoconf_fftw3.patch b/sci-electronics/ngspice/files/ngspice-27-autoconf_fftw3.patch
new file mode 100644
index 000000000000..d0eec127c572
--- /dev/null
+++ b/sci-electronics/ngspice/files/ngspice-27-autoconf_fftw3.patch
@@ -0,0 +1,26 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -191,6 +191,10 @@
+ AC_ARG_WITH([ngshared],
+ [AS_HELP_STRING([--with-ngshared], [Compiles ngspice as shared library (dll)])])
+
++# --with-fftw3: Use fftw3 for Fourier transforms. Default is "yes".
++AC_ARG_WITH([fftw3],
++ [AS_HELP_STRING([--with-fftw3[=yes/no]], [Use fftw3 for Fourier transforms. Default=yes.])])
++
+ # readline and editline cannot both be enabled
+ if test "x$with_editline" = xyes; then
+ if test "x$with_readline" = xyes; then
+@@ -726,10 +730,12 @@
+ # Look for math library:
+ AC_CHECK_LIB([m], [sqrt])
+ AC_CHECK_HEADERS([float.h limits.h values.h ieeefp.h])
++if test "x$with_fftw3" != xno; then
+ AC_CHECK_HEADERS([fftw3.h])
+ AC_CHECK_LIB([fftw3], [fftw_plan_dft_1d],
+ [AC_DEFINE([HAVE_LIBFFTW3], [], [Have fft routines in libfftw3])
+ LIBS="$LIBS -lfftw3"])
++fi
+
+ # Check for a few mathematical functions:
+ AC_CHECK_FUNCS([erfc logb scalb scalbn asinh acosh atanh finite])
diff --git a/sci-electronics/ngspice/files/ngspice-27-split_terminfo.patch b/sci-electronics/ngspice/files/ngspice-27-split_terminfo.patch
new file mode 100644
index 000000000000..09f5ee29a3c9
--- /dev/null
+++ b/sci-electronics/ngspice/files/ngspice-27-split_terminfo.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1016,7 +1016,7 @@
+ AC_CHECK_HEADERS([readline/readline.h readline/history.h],
+ [AC_DEFINE([HAVE_GNUREADLINE], [], [Define if we have GNU readline])],
+ [AC_MSG_ERROR([Couldn't find GNU readline headers.])])
+- AC_SEARCH_LIBS([tputs], [ncurses termcap],
++ AC_SEARCH_LIBS([tputs], [ncurses termcap tinfo],
+ [AC_DEFINE([HAVE_TERMCAP], [], [Define if we have ncurses or termcap])],
+ [AC_MSG_ERROR([Found neither ncurses or termcap])])
+ AC_CHECK_LIB([readline], [readline],
+@@ -1036,7 +1036,7 @@
+ AC_CHECK_HEADERS([editline/readline.h],
+ [AC_DEFINE([HAVE_BSDEDITLINE], [1], [Define to enable BSD editline])],
+ [AC_MSG_ERROR([Couldn't find BSD editline headers.])])
+- AC_SEARCH_LIBS([tputs], [ncurses termcap],
++ AC_SEARCH_LIBS([tputs], [ncurses termcap tinfo],
+ [AC_DEFINE([HAVE_TERMCAP], [], [Define if we have ncurses or termcap])],
+ [AC_MSG_ERROR([Found neither ncurses or termcap])])
+ AC_CHECK_LIB([edit], [readline],