summaryrefslogtreecommitdiff
path: root/sci-electronics/netgen/netgen-1.4.52.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-electronics/netgen/netgen-1.4.52.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-electronics/netgen/netgen-1.4.52.ebuild')
-rw-r--r--sci-electronics/netgen/netgen-1.4.52.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-electronics/netgen/netgen-1.4.52.ebuild b/sci-electronics/netgen/netgen-1.4.52.ebuild
new file mode 100644
index 000000000000..0c90872fda8b
--- /dev/null
+++ b/sci-electronics/netgen/netgen-1.4.52.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="LVS tool (layout versus schematic comparison)"
+HOMEPAGE="http://www.opencircuitdesign.com/netgen/index.html"
+SRC_URI="http://www.opencircuitdesign.com/${PN}/archive/${P}.tgz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X"
+
+DEPEND="X? (
+ dev-lang/tcl:0
+ dev-lang/tk:0
+ x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4.40-tcl-bin-name.patch
+
+ if $(use X) ; then
+ cp -r "${S}" "${WORKDIR}"/with-x || die
+ fi
+}
+
+src_configure() {
+ cd scripts
+ econf --without-x
+
+ if $(use X) ; then
+ cd "${WORKDIR}"/with-x/scripts || die
+ econf --with-x
+ fi
+}
+
+src_compile() {
+ emake
+
+ if $(use X) ; then
+ cd "${WORKDIR}"/with-x || die
+ emake
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
+
+ if $(use X) ; then
+ cd "${WORKDIR}"/with-x || die
+ emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
+ fi
+
+ dodoc Changes README TO_DO
+}