summaryrefslogtreecommitdiff
path: root/sci-electronics/linsmith
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /sci-electronics/linsmith
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'sci-electronics/linsmith')
-rw-r--r--sci-electronics/linsmith/Manifest2
-rw-r--r--sci-electronics/linsmith/linsmith-0.99.31.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/sci-electronics/linsmith/Manifest b/sci-electronics/linsmith/Manifest
index 971f9985b38d..66e9abbddf2b 100644
--- a/sci-electronics/linsmith/Manifest
+++ b/sci-electronics/linsmith/Manifest
@@ -1,4 +1,6 @@
AUX linsmith-datafiles.patch 757 BLAKE2B 273a60d1b93046c015c178c6d037252c667016c3601c7830c9b4c0ff1c1b899c013660ee76034d143011d8c34b6077d137202f3398b9d7fbae3836105dcc69c9 SHA512 af6f38420a4adc8386c70c4837aee74ff5cf2994bc0edf230198cb41cd53dbee69aa08c497dccb5e20f6a89282b2f690995d7cd5f86b93c8ac0f6488f0c0d266
DIST linsmith-0.99.30.tar.gz 1132438 BLAKE2B fda024052d0aa1af7254aa37975a62bcb1bd2dbeb020202853bc32c85e6859bda6153fb5e6af8f18a4bf29a11c5eb7bd5eaacc68ebbf20b7d2622cc0d04d77d1 SHA512 d1f6cd3895b7c217de49c214f8b86b1bb9ce97d540546f0004b7f320b7cf142652cf0ec51ce48cf32b89564bf408546bf10d5f4937544cf9e8a4d87d1db5bed5
+DIST linsmith-0.99.31.tar.gz 1138998 BLAKE2B c8b32bf2530b87a0bb9f2b7914e5ccdb6c8ad28b57b919b93c4ed0fb272a2e61f588adb3794b81565580a68413f3cb4e43ac861c4a70cce105d3e821d21eccf3 SHA512 0218992243ff5db6efa39e01d7eddf6d44d921fe4caf131d020416d320a542f19bd577a3bbd9fc8df5f1ccb62ba152d02f825bab8fae55dadd262c5dce47c076
EBUILD linsmith-0.99.30-r1.ebuild 1526 BLAKE2B 0c720c439ffd249855c05770704749edb84762c80dcccc5bc9e5d95a49f79faccc17979a27d63bb0fd6dad23de118623d43ac6e27057b956de8d0ee0ebfcca1d SHA512 5eb2efd3f7332957e440e7b2fa057b6376577029634c53139aae465aa37b91a4cbb56ef01a1670e7033d46dd9d2deea9b7dc15f250028016ad930ecb1d438b86
+EBUILD linsmith-0.99.31.ebuild 1560 BLAKE2B efc9459a1c0fa0d13962a3aa5a543249ac76dbde5a22aeb31d2e75a4deccf1c06ec0a1c80dacdcab370dc98cdba9251abd646dac94e3b77abb75e7b3096cc15e SHA512 71efe7710912c3c2a22a91f28b3e566eb94078cecc36e4f02bb7b2cdb8d9a18cdddc5d23251252244eb9a6beb476518a7cbe90d5c3f1d5a825ada31480d5cfc4
MISC metadata.xml 473 BLAKE2B 397250ec12397650b2695e1ff89d5dfc9a3c556b64f6fc02c42427757c9c2ca8d0af8630854b611602f6cbf7d2ea66b529c7e4ea50d4d9a5ad7bf94dc15b14a0 SHA512 46151b41b8bacae4dc89d8ef861195f3c6baed7854c1ab176b5ab54b99cad27d92418a58739e2266491e2b4ec003000c4f694ca94c1e0257465ce1eb1b5c8f2b
diff --git a/sci-electronics/linsmith/linsmith-0.99.31.ebuild b/sci-electronics/linsmith/linsmith-0.99.31.ebuild
new file mode 100644
index 000000000000..af9078102c2a
--- /dev/null
+++ b/sci-electronics/linsmith/linsmith-0.99.31.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="Smith charting program, mainly designed for educational use"
+HOMEPAGE="http://www.jcoppens.com/soft/linsmith/index.en.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ dev-libs/atk
+ gnome-base/libgnome
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS NOTES README THANKS TODO )
+
+src_prepare() {
+ eapply_user
+
+ # This patch is to prevent make install copying
+ # the examples in /usr/share/linsmith
+ # Now they are cp to the correct location.
+ eapply -p0 "${FILESDIR}"/${PN}-datafiles.patch
+
+ # fix QA warnings about wrong categories and location of icon file
+ # in .desktop file
+ sed -i -e "s/Application;Engineering;/Education;Science;Electronics;/" \
+ -e "s/Encoding=/#Encoding=/" \
+ -e "s#pixmaps/linsmith/l#pixmaps/l#" \
+ ${PN}.desktop || die
+
+ # fix QA warnings about 'maintainer mode'
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto "/usr/share/${PN}"
+ doins datafiles/conv0809
+
+ einstalldocs
+ doman doc/${PN}.1
+
+ domenu ${PN}.desktop
+ doicon ${PN}_icon.xpm
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}"
+ doins doc/manual.pdf
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins datafiles/*.circ datafiles/*.load || die
+ fi
+}