summaryrefslogtreecommitdiff
path: root/sci-electronics/kicad-templates/kicad-templates-6.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-25 14:49:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-25 14:49:58 +0100
commitef89e12d3986ab87064b84e073b2a4a11f32c91c (patch)
tree2e4bbfc20faa4927576eed7c8002b5e121f10047 /sci-electronics/kicad-templates/kicad-templates-6.0.7.ebuild
parentfae5c40540ab2ebf93e2291bfec510022df02bdc (diff)
gentoo auto-resync : 25:08:2022 - 14:49:58
Diffstat (limited to 'sci-electronics/kicad-templates/kicad-templates-6.0.7.ebuild')
-rw-r--r--sci-electronics/kicad-templates/kicad-templates-6.0.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-electronics/kicad-templates/kicad-templates-6.0.7.ebuild b/sci-electronics/kicad-templates/kicad-templates-6.0.7.ebuild
new file mode 100644
index 000000000000..fcdb94bb2f13
--- /dev/null
+++ b/sci-electronics/kicad-templates/kicad-templates-6.0.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Electronic Schematic and PCB design tools project templates"
+HOMEPAGE="https://github.com/kicad/kicad-templates"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/libraries/${PN}.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://gitlab.com/kicad/libraries/${PN}/-/archive/${MY_PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ fi
+
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+
+RDEPEND=">=sci-electronics/kicad-6.0.0"