summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-14 10:46:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-14 10:46:43 +0100
commitd938920a33f03124f4e211a67d9291283442caa1 (patch)
tree8df88b987b9cf96366e7bdab6bec0f5606c6153d /sci-chemistry
parent8d3092381b8c63ad0261911737e91cc4fda109c9 (diff)
gentoo auto-resync : 14:09:2023 - 10:46:43
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/Manifest.gzbin9516 -> 9523 bytes
-rw-r--r--sci-chemistry/autodock/Manifest2
-rw-r--r--sci-chemistry/autodock/autodock-4.2.6-r1.ebuild111
3 files changed, 113 insertions, 0 deletions
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index 79ec0479774d..5156f0811930 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ
diff --git a/sci-chemistry/autodock/Manifest b/sci-chemistry/autodock/Manifest
index 0d730f7dbef4..a0b6ea4c08fc 100644
--- a/sci-chemistry/autodock/Manifest
+++ b/sci-chemistry/autodock/Manifest
@@ -1,4 +1,6 @@
AUX autodock-4.2.6-buildsystem.patch 1480 BLAKE2B 3f1884ee05e062cb630b43fe3e8ecf6f827ada23d5d3060a5bb3d7e854f7c5e2d2b1f7a476c4effcdcbab4292b33fae093474773a31a6995465d00dbbb721246 SHA512 9c5b05f4831049c2c064358df26124526973110ddd31ffa7930f185694f9258dfce648085a96f05a2173aa61b4cdcda7a6fe170a56160708e031fb248f9e6bbe
+DIST autodock-4.2.6-drop-register-keyword.patch 36676 BLAKE2B d91969d9d84b8940ddabf34dc017174deb1dafe0867f9ff5d2e528c4f3b4086b285f299220caa9406139146d460c2fba529e8b85c4aee927cabbdf34e91d3541 SHA512 39358c1d70f80c0a54066eb9ef600980c993dffaf1f7b7d558d29a4404c00a4d02ba0e871ae538474e452425f79795aad38eb0fca38a2663ccf6a64f57a40933
DIST autodocksuite-4.2.6-src.tar.gz 35438010 BLAKE2B 88e036ecc0492fb83f31b90fd0983ec57d889a61d17249f672a3e30e942f6c329dc2494088a8fc7c5bc39a5bdbb38fb1514f1750c7145374f202a928d477faa9 SHA512 75b8878f948c4f6bc28adb442997192dad0c36bbede2fd698623903cb27b06b4df3ba038bfc70fc13b4bdee864fd2344f0f7208be2020da4e01a00b842b46bbb
+EBUILD autodock-4.2.6-r1.ebuild 2426 BLAKE2B 3a01caee7704ffd3d39e4a9937d1a6f2c4b0801e6945edb43c4b7276135a683dbd84c3f6fc560df114c534e25d804d1aa975f45ccb322fa25fa0b9146cd03292 SHA512 f909c3d84fe8069f14e58392a6c358e39e79cc5e3449ca69c277fa9cf748042dd1c49ddb6d25da36f1a5bc488a052e729c3074a1fd72cf5dad3b01fec566836f
EBUILD autodock-4.2.6.ebuild 2206 BLAKE2B 0e457f425fac2908df23e03bf31865e985b0fdb85bdc2014e10bcbef1a00dbbf957b986eda9e7d9cce443cd9bbb1a8118076f3b7e3990eb02c86c559566c9bb3 SHA512 aef41ca8df16042995b25b6a3a07bb207fae458e60b97ec5d1b6918944540b500d9cf798cda52a8f2e12a2a6e9c5531e4565c03bc49a8e4210df1d96aec56102
MISC metadata.xml 272 BLAKE2B 531e98b72776bbe9126811b70943add0f6f43141b01cb75b17ac2c8d1cfb6a9b349022fd411894d2b8eeb0612a73db10aed4ba71f9624bd6dbd172a05fca2c76 SHA512 04f5575703aaaa95e575460ae3de428d3da173b3b741ab52b4aad31e381fef78b325f49f99622ec26a65024437759ea013fc525bd63ee553003c71afcc40d10c
diff --git a/sci-chemistry/autodock/autodock-4.2.6-r1.ebuild b/sci-chemistry/autodock/autodock-4.2.6-r1.ebuild
new file mode 100644
index 000000000000..463c23ee2e01
--- /dev/null
+++ b/sci-chemistry/autodock/autodock-4.2.6-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools readme.gentoo-r1
+
+MY_PN="autodocksuite"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A suite of automated docking tools"
+HOMEPAGE="https://autodock.scripps.edu/"
+SRC_URI="
+ https://autodock.scripps.edu/downloads/autodock-registration/tars/dist$(ver_rs 1- '')/${MY_P}-src.tar.gz
+ https://dev.gentoo.org/~andrewammerlaan/${PN}-4.2.6-drop-register-keyword.patch
+"
+S="${WORKDIR}/src"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples openmp"
+# Tests require python2
+RESTRICT="test"
+
+# False positives caused by nested configure scripts
+QA_CONFIGURE_OPTIONS=".*"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+The AutoDock development team requests all users to fill out the
+registration form at:
+
+http://autodock.scripps.edu/downloads/autodock-registration
+
+The number of unique users of AutoDock is used by Prof. Arthur J.
+Olson and the Scripps Research Institude to support grant
+applications.
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buildsystem.patch
+ "${DISTDIR}"/${PN}-4.2.6-drop-register-keyword.patch
+)
+
+src_prepare() {
+ default
+
+ local i
+
+ sed \
+ -e "s/\tcsh/\tsh/" \
+ -i auto{dock,grid}/Makefile.am || die
+ for i in autodock autogrid; do
+ pushd $i &>/dev/null
+ eautoreconf
+ popd &>/dev/null
+ done
+}
+
+src_configure() {
+ local i
+ for i in autodock autogrid; do
+ pushd $i &>/dev/null
+ econf $(use_enable openmp)
+ popd &>/dev/null
+ done
+}
+
+src_compile() {
+ emake -C autodock
+ emake -C autogrid
+}
+
+# Refer: https://github.com/gentoo/gentoo/pull/31489/files#r1321120609
+#src_test() {
+# elog "Testing autodock"
+# cd "${S}/autodock/Tests" || die
+# cp ../*.dat . || die
+# ${EPYTHON} test_autodock4.py || die "AutoDock tests failed."
+# einfo "Testing autogrid"
+# cd "${S}/autogrid/Tests" || die
+# ${EPYTHON} test_autogrid4.py || die "AutoGrid tests failed."
+#}
+
+src_install() {
+ if use openmp; then
+ newbin autodock/autodock4.omp ${PN}4
+ dobin autogrid/autogrid4
+ else
+ dobin autodock/autodock4 autogrid/autogrid4
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r \
+ autodock/{AD4_parameters.dat,AD4_PARM99.dat} \
+ $(usex examples "autodock/EXAMPLES" "")
+
+ DOCS=(
+ RELEASENOTES
+ autodock/{AUTHORS,README}
+ autodock/USERGUIDES/AutoDock4.{0,1,2}_UserGuide.doc
+ autodock/USERGUIDES/AutoDock4.2_UserGuide.pdf
+ )
+ einstalldocs
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}