summaryrefslogtreecommitdiff
path: root/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild')
-rw-r--r--sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild b/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild
new file mode 100644
index 000000000000..033619474de5
--- /dev/null
+++ b/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Cross conversion environment of NMR spectra"
+HOMEPAGE="http://fermi.pharm.hokudai.ac.jp/olivia/api/index.php/Xyza2pipe_src"
+SRC_URI="http://fermi.pharm.hokudai.ac.jp/olivia/documents/xyza2pipe.tgz -> ${P}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="olivia"
+IUSE=""
+
+S="${WORKDIR}"/${PN}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ tc-export CC
+ mkdir bin || die
+}
+
+src_install() {
+ local i
+ dodoc README FEEDBACK
+ cd bin || die
+ for i in *; do
+ newbin ${i}{,-olivia}
+ done
+}