summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca-ctp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/votca-ctp
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/votca-ctp')
-rw-r--r--sci-chemistry/votca-ctp/Manifest2
-rw-r--r--sci-chemistry/votca-ctp/metadata.xml15
-rw-r--r--sci-chemistry/votca-ctp/votca-ctp-9999.ebuild50
3 files changed, 67 insertions, 0 deletions
diff --git a/sci-chemistry/votca-ctp/Manifest b/sci-chemistry/votca-ctp/Manifest
new file mode 100644
index 000000000000..a52bb500d9a3
--- /dev/null
+++ b/sci-chemistry/votca-ctp/Manifest
@@ -0,0 +1,2 @@
+EBUILD votca-ctp-9999.ebuild 1012 SHA256 b89cdab2de96d00c455b25af5de51612a373b13c9306a52557380ff9becb74b9 SHA512 192e30c106f1c43d8edb784b497b830bf4fa8df8c2b9e704f1d76068dea254f3a418338318c1cef2d718a30fa322626550b68fbf604183e33e6ca06f801e58bb WHIRLPOOL a23c432761ebbecb01999bfe92f5d2c32926d23a21bf2d41881fe1837b5808ced648d900fcdd9599afb963b62a0e3b6e837ea078882aafcf4b7693474b6db1ea
+MISC metadata.xml 453 SHA256 1450296640fecbb233a5fca2ea5fda8327bf842033ee963fdedabbe25d157005 SHA512 53ace87a281559ae8881b8b010c76801696521de930dcfaf12a5e320456cb4a21a55a7873d173bdb5cc740f3cdbccf1daf62bc83579342f4f23329df7dbd2dba WHIRLPOOL e8e17461069cde6ddef1de7122d7e0db18ffc8452bf659ee3c57dcdfd22168682c70baae7f810bcbc9c402912d6c38547d9050371a7eab907fe4f2816ed034b9
diff --git a/sci-chemistry/votca-ctp/metadata.xml b/sci-chemistry/votca-ctp/metadata.xml
new file mode 100644
index 000000000000..7b7ecf654688
--- /dev/null
+++ b/sci-chemistry/votca-ctp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>junghans@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">votca/ctp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/votca-ctp/votca-ctp-9999.ebuild b/sci-chemistry/votca-ctp/votca-ctp-9999.ebuild
new file mode 100644
index 000000000000..ba7ad052c5aa
--- /dev/null
+++ b/sci-chemistry/votca-ctp/votca-ctp-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils multilib
+
+IUSE=""
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Votca charge transport module"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ =sci-libs/votca-tools-${PV}[sqlite]
+ =sci-libs/votca-moo-${PV}
+ =sci-chemistry/votca-csg-${PV}"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README NOTICE CHANGELOG.md )
+
+src_configure() {
+ mycmakeargs=(
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA-CTP, J. Chem. Theo. Comp. 7, 3335-3345 (2011)"
+ einfo "https://dx.doi.org/10.1021/ct200388s"
+ einfo
+}