summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca-csgapps/votca-csgapps-1.6_rc1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-chemistry/votca-csgapps/votca-csgapps-1.6_rc1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-chemistry/votca-csgapps/votca-csgapps-1.6_rc1.ebuild')
-rw-r--r--sci-chemistry/votca-csgapps/votca-csgapps-1.6_rc1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csgapps/votca-csgapps-1.6_rc1.ebuild b/sci-chemistry/votca-csgapps/votca-csgapps-1.6_rc1.ebuild
new file mode 100644
index 000000000000..463cba8e0e38
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/votca-csgapps-1.6_rc1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Extra applications for votca-csg"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-cpp/eigen-3.3
+ ~sci-chemistry/${PN%apps}-${PV}"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )