summaryrefslogtreecommitdiff
path: root/sci-chemistry/shelx/shelx-20141228.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/shelx/shelx-20141228.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/shelx/shelx-20141228.ebuild')
-rw-r--r--sci-chemistry/shelx/shelx-20141228.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-chemistry/shelx/shelx-20141228.ebuild b/sci-chemistry/shelx/shelx-20141228.ebuild
new file mode 100644
index 000000000000..541cbfb83802
--- /dev/null
+++ b/sci-chemistry/shelx/shelx-20141228.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Programs for crystal structure determination from single-crystal diffraction data"
+HOMEPAGE="http://shelx.uni-ac.gwdg.de/SHELX/"
+SRC_URI="
+ amd64? (
+ anode_amd64.bz2
+ ciftab_amd64.bz2
+ shelxc_amd64.bz2
+ shelxd_amd64.bz2
+ shelxe_amd64.bz2
+ shelxl_amd64.bz2
+ shelxs_amd64.bz2
+ shelxt_amd64.bz2
+ shredcif_amd64.bz2
+ )
+ x86? (
+ anode_x86.bz2
+ ciftab_x86.bz2
+ shelxc_x86.bz2
+ shelxd_x86.bz2
+ shelxe_x86.bz2
+ shelxl_x86.bz2
+ shelxs_x86.bz2
+ shelxt_x86.bz2
+ shredcif_x86.bz2
+ )
+"
+
+SLOT="0"
+LICENSE="free-noncomm"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"
+
+RESTRICT="fetch"
+
+QA_PREBUILT="opt/bin/*"
+
+pkg_nofetch() {
+ elog "Go to ${HOMEPAGE}"
+ elog "Fill out the application form, and send it in."
+ elog "Download ${A} and rename them to"
+ use amd64 && elog "*_amd64.bz2"
+ use x86 && elog "*_x86.bz2"
+ elog "and place renamed tarballs in ${DISTDIR}."
+}
+
+src_install() {
+ local i
+ into /opt
+ for i in *; do
+ newbin ${i} ${i/_*/}
+ done
+}