summaryrefslogtreecommitdiff
path: root/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild')
-rw-r--r--sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild b/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild
new file mode 100644
index 000000000000..7c143bf877ba
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-emovie/pymol-plugins-emovie-1.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+DESCRIPTION="PyMOL plugin for convinient movie creation"
+SRC_URI="http://www.weizmann.ac.il/ISPC/eMovie_package.zip"
+HOMEPAGE="http://www.weizmann.ac.il/ISPC/eMovie.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~x86-linux ~amd64-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >sci-chemistry/pymol-0.99[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-indent.patch
+}
+
+src_install(){
+ python_moduleinto pmg_tk/startup
+ python_foreach_impl python_domodule eMovie.py
+ python_foreach_impl python_optimize
+}