summaryrefslogtreecommitdiff
path: root/sci-chemistry/probe/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/probe/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/probe/files')
-rw-r--r--sci-chemistry/probe/files/as-needed.patch21
-rw-r--r--sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch25
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-chemistry/probe/files/as-needed.patch b/sci-chemistry/probe/files/as-needed.patch
new file mode 100644
index 000000000000..9ddecf5f569e
--- /dev/null
+++ b/sci-chemistry/probe/files/as-needed.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index 68d7469..bcb821c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ MACHINEFLAGS =
+ CFLAGS = $(MACHINEFLAGS)
+-LFLAGS = -lm $(MACHINEFLAGS)
++LFLAGS = -lm
+ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ parse.o atomprops.o stdconntable.o autobondrot.o hybrid_36_c.o
+
+@@ -8,7 +8,7 @@ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ cc -c $*.c $(CFLAGS)
+
+ probe: probe.o $(OBJLIST)
+- cc -o $@ probe.o $(OBJLIST) $(LFLAGS)
++ cc $(MACHINEFLAGS) -o $@ probe.o $(OBJLIST) $(LFLAGS)
+
+ clean:
+ @rm -f *.o *.ckp
diff --git a/sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch b/sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch
new file mode 100644
index 000000000000..df7040c3ba1d
--- /dev/null
+++ b/sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch
@@ -0,0 +1,25 @@
+ Makefile | 8 +++-----
+ 1 files changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 9031bd0..8f74d6a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,14 +1,12 @@
+-MACHINEFLAGS =
+-CFLAGS = $(MACHINEFLAGS)
+-LFLAGS = -static -lm $(MACHINEFLAGS)
++LIBS = -lm
+ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ parse.o atomprops.o stdconntable.o autobondrot.o hybrid_36_c.o
+
+ .c.o:
+- cc -c $*.c $(CFLAGS)
++ $(CC) $(CFLAGS) -c $*.c
+
+ probe: probe.o $(OBJLIST)
+- cc -o $@ probe.o $(OBJLIST) $(LFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ probe.o $(OBJLIST) $(LIBS)
+
+ clean:
+ @rm -f *.o *.ckp