summaryrefslogtreecommitdiff
path: root/sci-chemistry/pdbmat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-chemistry/pdbmat
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-chemistry/pdbmat')
-rw-r--r--sci-chemistry/pdbmat/Manifest4
-rw-r--r--sci-chemistry/pdbmat/files/CMakeLists.txt6
-rw-r--r--sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild (renamed from sci-chemistry/pdbmat/pdbmat-3.89.ebuild)15
3 files changed, 13 insertions, 12 deletions
diff --git a/sci-chemistry/pdbmat/Manifest b/sci-chemistry/pdbmat/Manifest
index d57f17b0d3ea..de4213c342e2 100644
--- a/sci-chemistry/pdbmat/Manifest
+++ b/sci-chemistry/pdbmat/Manifest
@@ -1,4 +1,4 @@
-AUX CMakeLists.txt 414 BLAKE2B bdc6bbe4b5fc80e208dece51e29f3d7b429655d57e0406c5d08fd41b069577574f0cb1b75b406a21aed14479bc7679a386e92a6af66dbdac325291ef6414dbbe SHA512 d539a6cc947cf6f16d634ccc5e2c0f1783f000564cc78c2103c1bcbc8619cb7f0d97a461ffa91ab3fb7d4dbe11102614983456c9bd8597a2f4d9f9a6538185ff
+AUX CMakeLists.txt 457 BLAKE2B 777b9e218731ffe6dc50f32996420703ddbc9778580c4040aafed7ca36192b3b689b6cd9311a9d12ccd8349ac41f974c8d518dcd87d6ff615e8e2d8403c8bd03 SHA512 1df9f68ccb2a5ad481695daf2845b62affe5bffad23b596f68e2589e199e009ce79b9c873a00c0e44afaf23a1e0f5dd7526ff828b45350d562505af1de795268
DIST pdbmat-3.89.tar.gz 124727 BLAKE2B ed74b4278d85d21f97a6268f2554478e5da0c871be6d071d54edf964b10f92518f1869a77a6718e2c2b6b8c61b8e4659ccb84f9ee829d4351f23abd727c113cf SHA512 2c7f8f32344fe1abc662878c2556c10bd6671e683787231827399866f485389c3a63253b00d5a5bdbe8d0b8b779891e846962c9372d927b94c45f0fac59a4fb6
-EBUILD pdbmat-3.89.ebuild 649 BLAKE2B 4ca393b9d4ac572b263f7f16a8d3bafe4710cad3630bd4617c7f184e01c56c1e2dfded7d14f2e5a95e0432178c3acebd9fa0a4cf2a48ab4abfb47c00f12296db SHA512 22e5765e35daab42e8c013ee1a2ddc8b08318d215c1eea6def16ff0559be4f5d521ed85f73fc82fbac3d0a0ae06fc07935bb666fdccf47f1268316a668b1f3e7
+EBUILD pdbmat-3.89-r1.ebuild 627 BLAKE2B 84059446492f20698941c11580733ec5f911aa23f325d2add1a29c3adb15fc91d652fc5fa8df8080e16dc94e87642c54814e1f9e7dd2a76e2f2769caf17ee8a3 SHA512 29a76ba319604baa5826d1bc4e3f285e73be18c9a2daf8eac560c35eb2beff6518ccabcacd0067b3d24308afc0164c745bd0cd6b6e8ba061b3b73ee6ee666ea8
MISC metadata.xml 1092 BLAKE2B 4dd0c655057ada7c10630baaab4c9e83c3617b57ccb05367db0b90362c3473b18b8cc7fb3daf3ce0bbcd513c364db7f8f3102a73bf111632b3f79567bc755788 SHA512 7d07b337f08658ef9fbdda6392a8b49ca77139e1d52136d74f4ce627a5fe1062fa52b33ae94eb6273ac7a4511c6c74da21549f9e6d46b3e49c6f4fbfe83aebe4
diff --git a/sci-chemistry/pdbmat/files/CMakeLists.txt b/sci-chemistry/pdbmat/files/CMakeLists.txt
index 2f1937d84b3f..a20199bbca91 100644
--- a/sci-chemistry/pdbmat/files/CMakeLists.txt
+++ b/sci-chemistry/pdbmat/files/CMakeLists.txt
@@ -1,14 +1,16 @@
cmake_minimum_required (VERSION 2.6)
project (PDBMAT Fortran)
+include(GNUInstallDirs)
+
option (EXAMPLES "Instal additional example files" OFF)
add_executable(diagstd diagstd.f)
add_executable(pdbmat pdbmat.f)
install (TARGETS diagstd pdbmat DESTINATION bin)
-install (FILES diagstd.README pdbmat.README DESTINATION share/doc/pdbmat)
+install (FILES diagstd.README pdbmat.README DESTINATION ${CMAKE_INSTALL_DOCDIR})
if ( EXAMPLES )
- install (DIRECTORY ../Try_ENM2011 DESTINATION share/pdbmat/examples)
+ install (DIRECTORY ../Try_ENM2011 DESTINATION ${CMAKE_INSTALL_DOCDIR}/examples)
endif (EXAMPLES)
diff --git a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild b/sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild
index 6c14461b5019..40ef7c9df2d3 100644
--- a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
+++ b/sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils fortran-2
+inherit cmake fortran-2
DESCRIPTION="Calculate Tirion's model from pdb structures"
HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
SRC_URI="http://ecole.modelisation.free.fr/enm2011.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/Source_ENM2011
-SLOT="0"
LICENSE="CeCILL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples"
-S="${WORKDIR}"/Source_ENM2011
-
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -27,5 +26,5 @@ src_configure() {
-DEXAMPLES=$(usex examples)
)
- cmake-utils_src_configure
+ cmake_src_configure
}