summaryrefslogtreecommitdiff
path: root/sci-chemistry/molequeue
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /sci-chemistry/molequeue
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'sci-chemistry/molequeue')
-rw-r--r--sci-chemistry/molequeue/Manifest3
-rw-r--r--sci-chemistry/molequeue/files/molequeue-0.8.0-cmake.patch106
-rw-r--r--sci-chemistry/molequeue/molequeue-0.8.0.ebuild26
3 files changed, 124 insertions, 11 deletions
diff --git a/sci-chemistry/molequeue/Manifest b/sci-chemistry/molequeue/Manifest
index 93372b06da13..65a52494b05b 100644
--- a/sci-chemistry/molequeue/Manifest
+++ b/sci-chemistry/molequeue/Manifest
@@ -1,3 +1,4 @@
+AUX molequeue-0.8.0-cmake.patch 4285 BLAKE2B 916f0c248f487b6d7c11dd34e20364b5dfb494d2e27e657bc5a13f9d6c3f71ae2ab6818bace7df04c0a1388f6f85c42e3e0ab96fc5d3d892c0a95612532baf28 SHA512 9031fd3e5efe0a9332db4b1f46d82486fc804cef55c9fab35030bc562d1a40f5f16a02a5eb8c31bf4c50c7a0abcf22c11da5bdd4e2a45a37a8b6f4ff994d3ad6
DIST molequeue-0.8.0.tar.gz 643072 BLAKE2B c9ba0a93e4dac3027de1aeb5ae6c62fc3e4229786973d6c3b56af4b70476b0ed54a563837d489912a40c76b9ce0013e13633a327eb314c34305ba17d7f0b4cf7 SHA512 b9539d2ad2c67188ad254f186c1d67c122a15a32047801c632a1613a4f9c887f38baf2da1bb80cb123391948c2a44604fb1082e475ca6de1e683fbe51266ac84
-EBUILD molequeue-0.8.0.ebuild 1555 BLAKE2B 9ecafc79e0a82bf653b8b6b7d8f28103a2d14c795624b641e4046f29a777c577cd2f850d9c8397ab6bace5e6d1c9c01cec2287760df08c64dc38ea77efba91ab SHA512 ba103e6c00b1957389c5b092fce810bb4ed3b2e32b432f93643fd093118f9106829f2091bee9f80cded61b88cf81a92baf5d9902894072df12e319f78e316e55
+EBUILD molequeue-0.8.0.ebuild 1613 BLAKE2B 21ddbe84fb9ad674cc796330ee2a26f5fdcfc7f6187869d2775e5679bbb2bf2dc147d80c79617867f9b1424bf07eb797315fb5cab3cb59359c39171315cf353c SHA512 6971db16063f3c1dfad7a780adae7aaf438c2957f46698a1739a65ac3d658ccac501f687db18eddc1305a4e6a220cac206d781f5783cdcb0d38b4e952c550ed7
MISC metadata.xml 1257 BLAKE2B 181f9234f11d0cb14fd6b93b42ef153c089d4df8dcb7cf72bc710dbee11bf4bb573f37ea703d02dbe17fa1f39c0aaf591c6d28ad1429abced5108b9ce39f2030 SHA512 10e3dd48ec1e54bc0d47d4c2f0aca427875cc0ceb59a93ab41ab2734607aa6474e80f3ae622e45fa319753591f16439118dd0b301068cb3e16fd79ff11a4f058
diff --git a/sci-chemistry/molequeue/files/molequeue-0.8.0-cmake.patch b/sci-chemistry/molequeue/files/molequeue-0.8.0-cmake.patch
new file mode 100644
index 000000000000..3fd8a9db76be
--- /dev/null
+++ b/sci-chemistry/molequeue/files/molequeue-0.8.0-cmake.patch
@@ -0,0 +1,106 @@
+From 45cbc9f167d1158bc73e87618cc08ede2e3f2911 Mon Sep 17 00:00:00 2001
+From: "Marcus D. Hanwell" <marcus.hanwell@kitware.com>
+Date: Thu, 1 Jun 2017 13:17:20 -0400
+Subject: [PATCH] Removed GenerateExportHeader, bumped CMake min
+
+Removed the GenerateExportHeader copy we had, use CMake's, and bump the
+minimum to ensure it has the features we expect.
+---
+ CMakeLists.txt | 2 +-
+ cmake/GenerateExportHeader.cmake | 375 ---------------------------------------
+ cmake/exportheader.cmake.in | 35 ----
+ 3 files changed, 1 insertion(+), 411 deletions(-)
+ delete mode 100644 cmake/GenerateExportHeader.cmake
+ delete mode 100644 cmake/exportheader.cmake.in
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index df93bc8..a107c8f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
++cmake_minimum_required(VERSION 3.3 FATAL_ERROR)
+
+ project(MoleQueue)
+
+From aae92632d10fe98728c3e73bfd891e502e8712fd Mon Sep 17 00:00:00 2001
+From: "Marcus D. Hanwell" <marcus.hanwell@kitware.com>
+Date: Thu, 16 Nov 2017 15:10:25 -0500
+Subject: [PATCH] Remove deprecated calls for export flags
+
+Move them to the project default variables in the top level.
+---
+ CMakeLists.txt | 8 ++++++++
+ molequeue/client/CMakeLists.txt | 1 -
+ molequeue/servercore/CMakeLists.txt | 1 -
+ molequeue/zeromq/CMakeLists.txt | 1 -
+ thirdparty/qt5json/CMakeLists.txt | 1 -
+ 5 files changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a107c8f..e68d81f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,6 +4,14 @@ project(MoleQueue)
+
+ set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
+
++# Request C++11 standard, using new CMake variables.
++set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD_REQUIRED True)
++set(CMAKE_CXX_EXTENSIONS False)
++# Set symbol visibility defaults for all targets.
++set(CMAKE_CXX_VISIBILITY_PRESET "hidden")
++set(CMAKE_VISIBILITY_INLINES_HIDDEN True)
++
+ include(BuildType)
+ include(BuildLocation)
+ include(CompilerFlags)
+diff --git a/molequeue/client/CMakeLists.txt b/molequeue/client/CMakeLists.txt
+index 674f91a..8cb131a 100644
+--- a/molequeue/client/CMakeLists.txt
++++ b/molequeue/client/CMakeLists.txt
+@@ -20,7 +20,6 @@ set_target_properties(MoleQueueClient PROPERTIES AUTOMOC TRUE)
+ include(GenerateExportHeader)
+ generate_export_header(MoleQueueClient EXPORT_FILE_NAME molequeueclientexport.h)
+ list(APPEND headers "${CMAKE_CURRENT_BINARY_DIR}/molequeueclientexport.h")
+-add_compiler_export_flags(molequeue_export_flags)
+ set_property(TARGET MoleQueueClient APPEND
+ PROPERTY COMPILE_FLAGS ${molequeue_export_flags})
+
+diff --git a/molequeue/servercore/CMakeLists.txt b/molequeue/servercore/CMakeLists.txt
+index 8d4f7ee..aab0bec 100644
+--- a/molequeue/servercore/CMakeLists.txt
++++ b/molequeue/servercore/CMakeLists.txt
+@@ -30,7 +30,6 @@ set(hdrs
+ generate_export_header(MoleQueueServerCore
+ EXPORT_FILE_NAME molequeueservercoreexport.h)
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})
+-add_compiler_export_flags(molequeue_export_flags)
+ set_property(TARGET MoleQueueServerCore APPEND
+ PROPERTY COMPILE_FLAGS ${molequeue_export_flags})
+
+diff --git a/molequeue/zeromq/CMakeLists.txt b/molequeue/zeromq/CMakeLists.txt
+index bc1e893..188f437 100644
+--- a/molequeue/zeromq/CMakeLists.txt
++++ b/molequeue/zeromq/CMakeLists.txt
+@@ -20,7 +20,6 @@ target_link_libraries(MoleQueueZeroMq MoleQueueServerCore ${ZeroMQ_LIBRARIES})
+ generate_export_header(MoleQueueZeroMq
+ EXPORT_FILE_NAME molequeuezeromqexport.h)
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})
+-add_compiler_export_flags(molequeue_export_flags)
+ set_property(TARGET MoleQueueZeroMq APPEND
+ PROPERTY COMPILE_FLAGS ${molequeue_export_flags})
+
+diff --git a/thirdparty/qt5json/CMakeLists.txt b/thirdparty/qt5json/CMakeLists.txt
+index 6d00685..52f5df2 100644
+--- a/thirdparty/qt5json/CMakeLists.txt
++++ b/thirdparty/qt5json/CMakeLists.txt
+@@ -54,7 +54,6 @@ include(GenerateExportHeader)
+ generate_export_header(${QT5_JSON_LIBRARY_NAME}
+ EXPORT_FILE_NAME qt5jsonexport.h
+ EXPORT_MACRO_NAME QT5JSON_EXPORT)
+-add_compiler_export_flags(qt5json_export_flags)
+
+ set_property(TARGET ${QT5_JSON_LIBRARY_NAME} APPEND
+ PROPERTY COMPILE_FLAGS ${qt5json_export_flags})
diff --git a/sci-chemistry/molequeue/molequeue-0.8.0.ebuild b/sci-chemistry/molequeue/molequeue-0.8.0.ebuild
index 3b5733ea45d2..2c20c0bfeeac 100644
--- a/sci-chemistry/molequeue/molequeue-0.8.0.ebuild
+++ b/sci-chemistry/molequeue/molequeue-0.8.0.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils multilib python-single-r1 versionator virtualx
+inherit cmake-utils python-single-r1 versionator virtualx
DESCRIPTION="Abstract, manage and coordinate execution of tasks"
-HOMEPAGE="http://www.openchemistry.org/OpenChemistry/project/molequeue.html"
+HOMEPAGE="https://www.openchemistry.org/projects/molequeue/"
SRC_URI="https://github.com/OpenChemistry/molequeue/archive/${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
@@ -22,27 +22,33 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
RDEPEND="${PYTHON_DEPS}
dev-qt/qtcore:5
+ dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
zeromq? ( net-libs/cppzmq:0= )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
+
src_prepare() {
cmake-utils_src_prepare
+
+ rm cmake/{GenerateExportHeader.cmake,exportheader.cmake.in} || die
+
# delete bundled Qt5Json library
rm -r thirdparty || die
}
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_enable test TESTING)
- $(cmake-utils_use_use zeromq ZERO_MQ)
- $(cmake-utils_use_build doc DOCUMENTATION)
- $(cmake-utils_use client MoleQueue_BUILD_CLIENT)
- $(cmake-utils_use server MoleQueue_BUILD_APPLICATION)
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DMoleQueue_BUILD_CLIENT=$(usex client)
+ -DoleQueue_BUILD_APPLICATION=$(usex server)
+ -DENABLE_TESTING=$(usex test)
+ -DUSE_ZERO_MQ=$(usex zeromq)
-DINSTALL_LIBRARY_DIR=$(get_libdir)
- )
+ )
use zeromq && \
mycmakeargs+=( -DZeroMQ_ROOT_DIR=\"${EPREFIX}/usr\" )