summaryrefslogtreecommitdiff
path: root/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild')
-rw-r--r--sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild b/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild
new file mode 100644
index 000000000000..2ac95db2c57d
--- /dev/null
+++ b/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read, write and analyze MD trajectories with only a few lines of Python code"
+HOMEPAGE="http://mdtraj.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ sed -e "s:re.match('build.*(mdtraj.*)', output_dir).group(1):'.':g" \
+ -i basesetup.py || die
+ distutils-r1_python_prepare_all
+}