summaryrefslogtreecommitdiff
path: root/sci-chemistry/hollow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/hollow
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/hollow')
-rw-r--r--sci-chemistry/hollow/Manifest5
-rw-r--r--sci-chemistry/hollow/hollow-1.2-r1.ebuild38
-rw-r--r--sci-chemistry/hollow/metadata.xml11
3 files changed, 54 insertions, 0 deletions
diff --git a/sci-chemistry/hollow/Manifest b/sci-chemistry/hollow/Manifest
new file mode 100644
index 000000000000..6cc0e4d4acff
--- /dev/null
+++ b/sci-chemistry/hollow/Manifest
@@ -0,0 +1,5 @@
+DIST hollow-1.2.zip 62554 SHA256 9a2d97ad95fc102c1fd537e4fba3c1041ca0ba28d7d2dc0ddc8968b9d1b8722e SHA512 e253680cc0fae286ec697b2dac822b9e165d509cc7eefb27bbcafae6ab2617c3edc8cd9c8beefcc9ef2eb920c9d839fd0bc25f79d22160d857b1705cefbc05ca WHIRLPOOL 83d5d811defe43f91b3516dec873793d9aa6a6a93b2850289c1dd560d53b48a900c8064a16a33692edadb74d1c95b453c2c6fb3ff589a364b7393342e55f6587
+EBUILD hollow-1.2-r1.ebuild 832 SHA256 3c1eaac8dd1109f1835b59f81d8a5f7a348ccdd4cf72c28dfa09760f86804171 SHA512 bf29299b040db8f4f4cb3614671103c5d7ab927c8785538b06aacf72f0df36f39343308271db4ee54b9a87ad82895827e9bde1e151ca1eb17a2f11eb928821f9 WHIRLPOOL 325713d9e5d41b109324e792c1bb5224833b1c4da023498ee0f01eb48c2335a003d8f1f10a60f284433a0d1dad703ef99cda70ce87a859e714625b7a251640a0
+MISC ChangeLog 3117 SHA256 4d7b36cda31c3218850b31dc3a5e37345394cf3ed71881b54d238b1044183e43 SHA512 29eb805dc3983a06fb0b4546c2e66f68940392bfbb504c57b07d91f67724506658493db2bd341b02dc727cd40db980f6ab62f66aea42b6b73a5a79a05aac93e5 WHIRLPOOL 4ab24c22104993c89569bc891002e82e08e03254c411859e1b4511ca4f0a7725342660fc3da737893e91435e8112e5694f89db4b2f3995922200f018c72a7e30
+MISC ChangeLog-2015 750 SHA256 9921e7ead5aa842f47df7501f9b3570df00620fdfbd685f1df2213eafa89fa6e SHA512 2e42825740417aeb695ea69570bf421b90c14055d98bb946ac3c17d7bd99c20e24fff34062dda65f0d16037219bda40d218ba1cf80c39e05bf31b83c423ad61e WHIRLPOOL ac71c19fe3e0a561b99d0c7797b50bf022490d6f7133c8bf3ebc7d4188db2ffd292f267a8ef8d13fe1c7f36c2282fea4035f4f1ebfba7c84a84e387b3f6b6778
+MISC metadata.xml 351 SHA256 2b21d8fd7f37d0a6fe740b3b5190321df84651903520ac25b3abc4641d7da623 SHA512 977d69a6514595888b2a8c193a60dd2ae50ddde7bf9bbacc9051781aab58d50ff2543a911d270c1ed5e5bd152a23b8b2a3f03a186052c74d71c82939e30eeb27 WHIRLPOOL 797a91ab9269d98c25eb0a48432c5a6c4d2285d7bd364d1c42bbc15938fb8735c3d0d9098212272d02ee7fab38e1346e3ec07823c1282a80022a70b5548f19de
diff --git a/sci-chemistry/hollow/hollow-1.2-r1.ebuild b/sci-chemistry/hollow/hollow-1.2-r1.ebuild
new file mode 100644
index 000000000000..9c421e26b2bb
--- /dev/null
+++ b/sci-chemistry/hollow/hollow-1.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Production of surface images of proteins"
+HOMEPAGE="http://hollow.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${P}.zip"
+SRC_URI="http://hollow.sourceforge.net/${P}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND="${PYTHON_DEPS}
+ app-arch/unzip"
+
+src_install() {
+ python_setup
+ esvn_clean
+ python_foreach_impl python_domodule pdbstruct
+ python_moduleinto ${PN}
+ python_foreach_impl python_domodule *.py hollow.txt
+
+ python_foreach_impl python_newscript ${PN}.py ${PN}
+
+ dodoc README
+ python_optimize
+}
diff --git a/sci-chemistry/hollow/metadata.xml b/sci-chemistry/hollow/metadata.xml
new file mode 100644
index 000000000000..266ef9d56913
--- /dev/null
+++ b/sci-chemistry/hollow/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">hollow</remote-id>
+ </upstream>
+</pkgmetadata>