summaryrefslogtreecommitdiff
path: root/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r2.ebuild')
-rw-r--r--sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r2.ebuild b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r2.ebuild
new file mode 100644
index 000000000000..d9d29973585b
--- /dev/null
+++ b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fdo-mime
+
+DESCRIPTION="A collection of data files to add support for chemical MIME types"
+HOMEPAGE="http://chemical-mime.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/-data/}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ gnome-base/gnome-mime-data
+ x11-misc/shared-mime-info"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/desktop-file-utils
+ dev-libs/libxslt
+ media-gfx/imagemagick[xml,png,svg]
+ media-gfx/inkscape
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-turbomole.patch
+ "${FILESDIR}"/${P}-pigz.patch
+ "${FILESDIR}"/${P}-namespace-svg.patch
+ )
+
+src_prepare() {
+ # needed for convert/inkscape #464782
+ export XDG_CONFIG_HOME=$HOME/.config
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-update-database
+ --htmldir=/usr/share/doc/${PF}/html
+ )
+ autotools-utils_src_configure
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ ewarn "You can ignore any 'Unknown media type in type' warnings."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ ewarn "You can ignore any 'Unknown media type in type' warnings."
+}