summaryrefslogtreecommitdiff
path: root/sci-chemistry/chemex/chemex-2022.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-20 18:00:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-20 18:00:30 +0100
commit1e2d947ea35b8fd5d14d55f60265f9763fa70a72 (patch)
tree8ad6bc146973ea889b9e1add3cda534c60bd0ed1 /sci-chemistry/chemex/chemex-2022.3.4.ebuild
parentb92d3efc1e8f2a9c4b5a674b333eea5e6ad2c181 (diff)
gentoo auto-resync : 20:04:2023 - 18:00:30
Diffstat (limited to 'sci-chemistry/chemex/chemex-2022.3.4.ebuild')
-rw-r--r--sci-chemistry/chemex/chemex-2022.3.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/chemex-2022.3.4.ebuild b/sci-chemistry/chemex/chemex-2022.3.4.ebuild
new file mode 100644
index 000000000000..3df32b1ac247
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2022.3.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL="yes"
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/ChemEx/archive/refs/tags/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# FIXME: Restrict until tests are readded https://github.com/gbouvignies/ChemEx/issues/51
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/asteval-0.9.25[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-5.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lmfit-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.7.1[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.24.2[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.10.7[${PYTHON_USEDEP}]
+ >=dev-python/rapidfuzz-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.3.4[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.10.1[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest