summaryrefslogtreecommitdiff
path: root/sci-chemistry/chemex/chemex-2022.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-24 18:57:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-24 18:57:53 +0000
commitdbbd2ae5e62a232616ede4dae3ed69e15903940a (patch)
tree243873f2e5cf5d933e3da53166d4424201d84835 /sci-chemistry/chemex/chemex-2022.2.0.ebuild
parent1f23f671d001ca7a0073e504f5ae0184eb5d024d (diff)
gentoo auto-resync : 24:01:2023 - 18:57:53
Diffstat (limited to 'sci-chemistry/chemex/chemex-2022.2.0.ebuild')
-rw-r--r--sci-chemistry/chemex/chemex-2022.2.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/chemex-2022.2.0.ebuild b/sci-chemistry/chemex/chemex-2022.2.0.ebuild
new file mode 100644
index 000000000000..227f615edbcf
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2022.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL="yes"
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/ChemEx/archive/refs/tags/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# FIXME: Restrict until tests are readded https://github.com/gbouvignies/ChemEx/issues/51
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/asteval-0.9.25[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/lmfit-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.24.0[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.10.4[${PYTHON_USEDEP}]
+ >=dev-python/rapidfuzz-2.13.7[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.0.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest