summaryrefslogtreecommitdiff
path: root/sci-chemistry/chemex/chemex-2022.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-18 17:20:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-18 17:20:12 +0100
commit1b295861f983d29f9bd5d5906c7ca3cee4cf1f9a (patch)
tree1e7c76ef2f11271cde321f54bcd340b6e30afdd0 /sci-chemistry/chemex/chemex-2022.0.1-r1.ebuild
parent5142c1d68ca78d43985ab47bc3ae7c19954a9945 (diff)
gentoo auto-resync : 18:09:2022 - 17:20:12
Diffstat (limited to 'sci-chemistry/chemex/chemex-2022.0.1-r1.ebuild')
-rw-r--r--sci-chemistry/chemex/chemex-2022.0.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/chemex-2022.0.1-r1.ebuild b/sci-chemistry/chemex/chemex-2022.0.1-r1.ebuild
new file mode 100644
index 000000000000..9abd2a6493fb
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2022.0.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL="yes"
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/ChemEx/archive/refs/tags/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# FIXME: Restrict until tests are readded https://github.com/gbouvignies/ChemEx/issues/51
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/asteval-0.9.25[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/lmfit-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.5.3[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.23.3[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/rapidfuzz-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.5.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest