summaryrefslogtreecommitdiff
path: root/sci-chemistry/autodock_vina/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/autodock_vina/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/autodock_vina/files')
-rw-r--r--sci-chemistry/autodock_vina/files/1.1.2-gentoo.patch72
-rw-r--r--sci-chemistry/autodock_vina/files/autodock_vina-1.1.2-boost-filesystem.patch79
2 files changed, 151 insertions, 0 deletions
diff --git a/sci-chemistry/autodock_vina/files/1.1.2-gentoo.patch b/sci-chemistry/autodock_vina/files/1.1.2-gentoo.patch
new file mode 100644
index 000000000000..61ae8bec36f5
--- /dev/null
+++ b/sci-chemistry/autodock_vina/files/1.1.2-gentoo.patch
@@ -0,0 +1,72 @@
+ build/linux/debug/Makefile | 2 +-
+ build/linux/release/Makefile | 2 +-
+ build/makefile_common | 14 +++++++-------
+ 3 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/build/linux/debug/Makefile b/build/linux/debug/Makefile
+index 6a41cfc..8097fb9 100644
+--- a/build/linux/debug/Makefile
++++ b/build/linux/debug/Makefile
+@@ -1,7 +1,7 @@
+ BASE=/usr/local
+ BOOST_VERSION=1_41
+ BOOST_INCLUDE = $(BASE)/include
+-C_PLATFORM=-static -pthread
++C_PLATFORM=-pthread
+ GPP=/usr/local/bin/g++
+ C_OPTIONS= -g
+ BOOST_LIB_VERSION=
+diff --git a/build/linux/release/Makefile b/build/linux/release/Makefile
+index 1de1063..ded8133 100644
+--- a/build/linux/release/Makefile
++++ b/build/linux/release/Makefile
+@@ -1,7 +1,7 @@
+ BASE=/usr/local
+ BOOST_VERSION=1_41
+ BOOST_INCLUDE = $(BASE)/include
+-C_PLATFORM=-static -pthread
++C_PLATFORM=-pthread
+ GPP=/usr/local/bin/g++
+ C_OPTIONS= -O3 -DNDEBUG
+ BOOST_LIB_VERSION=
+diff --git a/build/makefile_common b/build/makefile_common
+index a940329..96336e8 100644
+--- a/build/makefile_common
++++ b/build/makefile_common
+@@ -2,29 +2,29 @@ LIBOBJ = cache.o coords.o current_weights.o everything.o grid.o szv_grid.o manif
+ MAINOBJ = main.o
+ SPLITOBJ = split.o
+
+-INCFLAGS = -I $(BOOST_INCLUDE)
++INCFLAGS = -I$(BOOST_INCLUDE)
+
+ # -pedantic fails on Mac with Boost 1.41 (syntax problems in their headers)
+ #CC = ${GPP} ${C_PLATFORM} -ansi -pedantic -Wno-long-long ${C_OPTIONS} $(INCFLAGS)
+ CC = ${GPP} ${C_PLATFORM} -ansi -Wno-long-long ${C_OPTIONS} $(INCFLAGS)
+
+-LDFLAGS = -L$(BASE)/lib -L.
++LDFLAGS += -L.
+
+-LIBS = -l boost_system${BOOST_LIB_VERSION} -l boost_thread${BOOST_LIB_VERSION} -l boost_serialization${BOOST_LIB_VERSION} -l boost_filesystem${BOOST_LIB_VERSION} -l boost_program_options${BOOST_LIB_VERSION}#-l pthread
++LIBS = -lboost_system -lboost_thread -lboost_serialization -lboost_filesystem -lboost_program_options -lpthread
+
+ .SUFFIXES: .cpp .o
+
+ %.o : ../../../src/lib/%.cpp
+- $(CC) $(CFLAGS) -o $@ -c $<
++ $(CC) $(CXXFLAGS) -o $@ -c $<
+
+ %.o : ../../../src/design/%.cpp
+- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
++ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<
+
+ %.o : ../../../src/main/%.cpp
+- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
++ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<
+
+ %.o : ../../../src/split/%.cpp
+- $(CC) $(CFLAGS) -I ../../../src/lib -o $@ -c $<
++ $(CC) $(CXXFLAGS) -I ../../../src/lib -o $@ -c $<
+
+ all: vina vina_split
+
diff --git a/sci-chemistry/autodock_vina/files/autodock_vina-1.1.2-boost-filesystem.patch b/sci-chemistry/autodock_vina/files/autodock_vina-1.1.2-boost-filesystem.patch
new file mode 100644
index 000000000000..298aaa9ab993
--- /dev/null
+++ b/sci-chemistry/autodock_vina/files/autodock_vina-1.1.2-boost-filesystem.patch
@@ -0,0 +1,79 @@
+ src/main/main.cpp | 10 +++++++++-
+ src/split/split.cpp | 11 ++++++++++-
+ 2 files changed, 19 insertions(+), 2 deletions(-)
+
+diff --git a/src/main/main.cpp b/src/main/main.cpp
+index f49c8f5..b566aa2 100644
+--- a/src/main/main.cpp
++++ b/src/main/main.cpp
+@@ -47,7 +47,7 @@
+ using boost::filesystem::path;
+
+ path make_path(const std::string& str) {
+- return path(str, boost::filesystem::native);
++ return path(str);
+ }
+
+ void doing(int verbosity, const std::string& str, tee& log) {
+@@ -661,7 +661,11 @@ Thank you!\n";
+ cpu, seed, verbosity, max_modes_sz, energy_range, log);
+ }
+ catch(file_error& e) {
++#if defined(BOOST_FILESYSTEM_VERSION) && BOOST_FILESYSTEM_VERSION >= 3
++ std::cerr << "\n\nError: could not open \"" << e.name.string() << "\" for " << (e.in ? "reading" : "writing") << ".\n";
++#else
+ std::cerr << "\n\nError: could not open \"" << e.name.native_file_string() << "\" for " << (e.in ? "reading" : "writing") << ".\n";
++#endif
+ return 1;
+ }
+ catch(boost::filesystem::filesystem_error& e) {
+@@ -673,7 +677,11 @@ Thank you!\n";
+ return 1;
+ }
+ catch(parse_error& e) {
++#if defined(BOOST_FILESYSTEM_VERSION) && BOOST_FILESYSTEM_VERSION >= 3
++ std::cerr << "\n\nParse error on line " << e.line << " in file \"" << e.file.string() << "\": " << e.reason << '\n';
++#else
+ std::cerr << "\n\nParse error on line " << e.line << " in file \"" << e.file.native_file_string() << "\": " << e.reason << '\n';
++#endif
+ return 1;
+ }
+ catch(std::bad_alloc&) {
+diff --git a/src/split/split.cpp b/src/split/split.cpp
+index 54c614b..bc5530e 100644
+--- a/src/split/split.cpp
++++ b/src/split/split.cpp
+@@ -38,7 +38,7 @@
+ using boost::filesystem::path;
+
+ path make_path(const std::string& str) {
+- return path(str, boost::filesystem::native);
++ return path(str);
+ }
+
+ std::string default_prefix(const std::string& input_name, const std::string& add) {
+@@ -208,7 +208,12 @@ Thank you!\n";
+ write_multimodel_pdbqt(tmp, ligand_prefix, flex_prefix);
+ }
+ catch(file_error& e) {
++
++#if defined(BOOST_FILESYSTEM_VERSION) && BOOST_FILESYSTEM_VERSION >= 3
++ std::cerr << "\n\nError: could not open \"" << e.name.string() << "\" for " << (e.in ? "reading" : "writing") << ".\n";
++#else
+ std::cerr << "\n\nError: could not open \"" << e.name.native_file_string() << "\" for " << (e.in ? "reading" : "writing") << ".\n";
++#endif
+ return 1;
+ }
+ catch(boost::filesystem::filesystem_error& e) {
+@@ -220,7 +225,11 @@ Thank you!\n";
+ return 1;
+ }
+ catch(parse_error& e) {
++#if defined(BOOST_FILESYSTEM_VERSION) && BOOST_FILESYSTEM_VERSION >= 3
++ std::cerr << "\n\nParse error on line " << e.line << " in file \"" << e.file.string() << "\": " << e.reason << '\n';
++#else
+ std::cerr << "\n\nParse error on line " << e.line << " in file \"" << e.file.native_file_string() << "\": " << e.reason << '\n';
++#endif
+ return 1;
+ }
+ catch(std::bad_alloc&) {