summaryrefslogtreecommitdiff
path: root/sci-chemistry/MDAnalysis/MDAnalysis-2.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
commit399fa07bfac673a8846466b16c76549e329b55b8 (patch)
tree29af17ef91f1bd986b8e615a96b61db7fad5df14 /sci-chemistry/MDAnalysis/MDAnalysis-2.4.1.ebuild
parent388a0747e5972613060d5ca13955b5cd7132533d (diff)
gentoo auto-resync : 20:05:2023 - 10:17:50
Diffstat (limited to 'sci-chemistry/MDAnalysis/MDAnalysis-2.4.1.ebuild')
-rw-r--r--sci-chemistry/MDAnalysis/MDAnalysis-2.4.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/sci-chemistry/MDAnalysis/MDAnalysis-2.4.1.ebuild b/sci-chemistry/MDAnalysis/MDAnalysis-2.4.1.ebuild
deleted file mode 100644
index 5e7d91b36bf3..000000000000
--- a/sci-chemistry/MDAnalysis/MDAnalysis-2.4.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A python library to analyze and manipulate molecular dynamics trajectories"
-HOMEPAGE="https://www.mdanalysis.org"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-# TODO: fix this
-# ImportError: MDAnalysis not installed properly. This can happen if your C extensions have not been built.
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/numpy-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.0.0[${PYTHON_USEDEP}]
- >=sci-biology/biopython-1.71[${PYTHON_USEDEP}]
- >=dev-python/networkx-1.0[${PYTHON_USEDEP}]
- >=dev-python/GridDataFormats-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/joblib-0.12[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-1.5.1[${PYTHON_USEDEP}]
- >=dev-python/mmtf-python-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/tqdm-4.43.0[${PYTHON_USEDEP}]
- >=dev-python/gsd-1.9.3[${PYTHON_USEDEP}]
- dev-python/threadpoolctl[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest