summaryrefslogtreecommitdiff
path: root/sci-calculators
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-02 02:23:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-02 02:23:07 +0000
commit9d7dcb261c1433eafda094d4f0524d4a2a781b8d (patch)
treeb4b4fa9bb34237d7753bb976e0026f23f007d513 /sci-calculators
parent5b7c114c09d07eecd00e6f7fb829563aae3597b9 (diff)
gentoo auto-resync : 02:01:2023 - 02:23:07
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/Manifest.gzbin3040 -> 3038 bytes
-rw-r--r--sci-calculators/bc-gh/Manifest4
-rw-r--r--sci-calculators/bc-gh/bc-gh-6.2.2.ebuild75
-rw-r--r--sci-calculators/bc-gh/metadata.xml1
4 files changed, 79 insertions, 1 deletions
diff --git a/sci-calculators/Manifest.gz b/sci-calculators/Manifest.gz
index afd96b787ba3..78da4e2cdc46 100644
--- a/sci-calculators/Manifest.gz
+++ b/sci-calculators/Manifest.gz
Binary files differ
diff --git a/sci-calculators/bc-gh/Manifest b/sci-calculators/bc-gh/Manifest
index 9cae7f7ce193..3aa52d1cdd00 100644
--- a/sci-calculators/bc-gh/Manifest
+++ b/sci-calculators/bc-gh/Manifest
@@ -1,3 +1,5 @@
DIST bc-6.1.1.tar.xz 455456 BLAKE2B 7945ac623740abd9cbd894c20b8a03006caf64d2ce9770ade930d912c52b4e29b107b524d4a95ebea99e31921b7940e39e1afdeec837b4a03d3ed4e11b9f517b SHA512 0e7fb4d4223ace8ba5c1961cc0d7eba475174f92b75529fde64446b5d80db5729f848fd95507570711d2b8928996c87e837e926d31028f32e3f97cad47567d39
+DIST bc-6.2.2.tar.xz 456672 BLAKE2B 02a6b9012f3b2d6b87be9112c6ccaea84bb121b1de4ebe1276b2151ff24ff445de0cf5a591c2802069e8c9a69c29ca4985a52117761cbb40bc129b70c6f98a49 SHA512 11389ebd522dddb4b255856452d4ff851915331e36682899e946a3eee46e6a3b7ac7d28a0be8b86fc79c230f8ea3d8f335a4722a0c49daa68c51b6c667e1d1fe
EBUILD bc-gh-6.1.1-r1.ebuild 531 BLAKE2B 01e4b10f6348e154c087d9a858b09b25077883336ebcee2822f7e3fd68d89f2751d287efc77e88cf19e18fcbf1de69a5e83251f67356cfd2ba2f2f9206b998fa SHA512 0dee8e858497443e77582ef6c6db02b98a88b52dc45d6303def7992ab5cf4cd6e4fe0b2686a2ed563c94181946a314d5b1492b1ed3d673e6e4ae09792ce808f6
-MISC metadata.xml 972 BLAKE2B 3246d762ce2c9c182efd7aaf1595cde2fddf6d81c59f88f9105443585b4b15fc9fcc583b5b767c3022b96fe8639ca679fa0ea76beb36e0bacd4fc0103e3a103c SHA512 a5400b2c288574c75c9598be449ddfdc878e047261388512cdc95b9077ec9e605471438c253551fde37c8b78918716e3523893aeba091db6d389b92184215f13
+EBUILD bc-gh-6.2.2.ebuild 2270 BLAKE2B 46bf08d527861d43f6ac67cded30b82349ac73df52aba7c2f29aba9ec632143274d46cc0895476fee66f8c7b08dc7ee81663b7188919cd272cdad76c089f4136 SHA512 c7eb6f141962faf01cb4abe68775241b188e3363c3a30dfb03e86e97ec08e4b990f1f3307fd2a80532bd7748288e9d430cb6e7110c80b16492acae5dd4930e58
+MISC metadata.xml 1026 BLAKE2B 485554b7cde72c012634de4dc5a434eb4207202e7a852a36b0ca27f1fcd740b903b1701c41ff3a41ebe1a0650fabb285da714a57714132532c64c0d073bef6f4 SHA512 d2a35c9354b830ebf67e4176f10ced13b2b51b3894d51739e4d1776146c23fa73aaf6418ff29e0c64f2467a4cefb46f42a33df4861657f218b47244b80f9a2f7
diff --git a/sci-calculators/bc-gh/bc-gh-6.2.2.ebuild b/sci-calculators/bc-gh/bc-gh-6.2.2.ebuild
new file mode 100644
index 000000000000..16361a1854fa
--- /dev/null
+++ b/sci-calculators/bc-gh/bc-gh-6.2.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="bc-${PV}"
+DESCRIPTION="Implementation of POSIX bc with GNU extensions"
+HOMEPAGE="
+ https://git.yzena.com/gavin/bc/
+ https://github.com/gavinhoward/bc/
+"
+SRC_URI="
+ https://github.com/gavinhoward/bc/releases/download/${PV}/${MY_P}.tar.xz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="libedit readline"
+
+DEPEND="
+ !readline? (
+ libedit? ( dev-libs/libedit:= )
+ )
+ readline? (
+ sys-libs/readline:=
+ sys-libs/ncurses:=
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ local myconf=(
+ # GNU and BSD bc's have slightly different behavior. This bc can act
+ # like both, changing at runtime with environment variables, but it
+ # needs defaults, which can be set at compile time. This option sets all
+ # of the defaults to match the GNU bc/dc since it's common on Linux.
+ -pGNU
+ # A lot of test results are generated first by a bc compatible with the
+ # GNU bc. If there is no GNU bc installed, then those tests should be
+ # skipped. That's what this option does. Without it, we would have a
+ # dependency cycle. Those tests are super long, anyway.
+ -G
+ # Disables the automatic stripping of binaries.
+ -T
+ # Enables installing all locales, which is important for packages.
+ -l
+ # Disables some "problematic" tests that need specific options on Linux
+ # to not trigger the OOM killer because malloc() lies.
+ -P
+ )
+ if use readline ; then
+ myconf+=( -r )
+ elif use libedit ; then
+ myconf+=( -e )
+ fi
+
+ local -x EXECSUFFIX="-gh"
+ local -x PREFIX="${EPREFIX}/usr"
+ ./configure.sh "${myconf[@]}" || die
+}
+
+src_test() {
+ # This is to fix a bug encountered on Arch. It is to ensure we don't get
+ # segfaults on `make check` when the error messages change because the error
+ # messages are passed to printf(); they have format specifiers. With these
+ # env vars, the internal error messages are used, instead of the installed
+ # locales, which might be different since the new locale files are not
+ # installed yet. (It is impossible to use uninstalled locales because of the
+ # poor design of POSIX locales.)
+ env LANG=C LC_ALL=C emake check
+}
diff --git a/sci-calculators/bc-gh/metadata.xml b/sci-calculators/bc-gh/metadata.xml
index cf7960fcff59..b16dce8c90eb 100644
--- a/sci-calculators/bc-gh/metadata.xml
+++ b/sci-calculators/bc-gh/metadata.xml
@@ -16,6 +16,7 @@
</maintainer>
<bugs-to>https://git.yzena.com/gavin/bc</bugs-to>
<doc>https://git.yzena.com/gavin/bc/src/branch/master/manuals</doc>
+ <remote-id type="github">gavinhoward/bc</remote-id>
</upstream>
<longdescription lang="en">
An implementation of POSIX bc and Unix dc with GNU extensions and some of