summaryrefslogtreecommitdiff
path: root/sci-calculators/galculator/galculator-2.1.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-calculators/galculator/galculator-2.1.4-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-calculators/galculator/galculator-2.1.4-r2.ebuild')
-rw-r--r--sci-calculators/galculator/galculator-2.1.4-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-calculators/galculator/galculator-2.1.4-r2.ebuild b/sci-calculators/galculator/galculator-2.1.4-r2.ebuild
new file mode 100644
index 000000000000..9c4543ffa3d2
--- /dev/null
+++ b/sci-calculators/galculator/galculator-2.1.4-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="GTK+ based algebraic and RPN calculator"
+HOMEPAGE="http://galculator.mnim.org/"
+SRC_URI="http://galculator.mnim.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
+src_prepare() {
+ default
+
+ # bug 566290
+ echo "src/flex_parser.c" >> po/POTFILES.skip || die
+}
+
+src_install() {
+ default
+ dodoc doc/shortcuts
+
+ mv "${ED}"/usr/share/{appdata,metainfo} || die
+}