summaryrefslogtreecommitdiff
path: root/sci-calculators/datamash/datamash-1.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /sci-calculators/datamash/datamash-1.7-r1.ebuild
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'sci-calculators/datamash/datamash-1.7-r1.ebuild')
-rw-r--r--sci-calculators/datamash/datamash-1.7-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-calculators/datamash/datamash-1.7-r1.ebuild b/sci-calculators/datamash/datamash-1.7-r1.ebuild
new file mode 100644
index 000000000000..f9a68c3f6149
--- /dev/null
+++ b/sci-calculators/datamash/datamash-1.7-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="command-line program for basic numeric, textual and statistical operations"
+HOMEPAGE="https://www.gnu.org/software/datamash/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linux-crypto nls openssl"
+
+CDEPEND="
+ openssl? ( dev-libs/openssl:= )
+"
+RDEPEND="
+ ${CDEPEND}
+ nls? ( virtual/libintl )
+"
+BDEPEND="
+ ${CDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with openssl) \
+ $(use_with linux-crypto)
+}