summaryrefslogtreecommitdiff
path: root/sci-calculators/datamash/datamash-1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:31:11 +0100
commitad6182343997a405079870a2fe91c4e0c6b94595 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /sci-calculators/datamash/datamash-1.5.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'sci-calculators/datamash/datamash-1.5.ebuild')
-rw-r--r--sci-calculators/datamash/datamash-1.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-calculators/datamash/datamash-1.5.ebuild b/sci-calculators/datamash/datamash-1.5.ebuild
new file mode 100644
index 000000000000..db1f765861fa
--- /dev/null
+++ b/sci-calculators/datamash/datamash-1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="command-line program for basic numeric, textual and statistical operations"
+HOMEPAGE="https://www.gnu.org/software/datamash/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linux-crypto nls openssl"
+
+CDEPEND="
+ openssl? ( dev-libs/openssl )
+"
+RDEPEND="
+ ${CDEPEND}
+ nls? ( virtual/libintl )
+"
+BDEPEND="
+ ${CDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with openssl) \
+ $(use_with linux-crypto)
+}