summaryrefslogtreecommitdiff
path: root/sci-calculators/datamash/datamash-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /sci-calculators/datamash/datamash-1.3.ebuild
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'sci-calculators/datamash/datamash-1.3.ebuild')
-rw-r--r--sci-calculators/datamash/datamash-1.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-calculators/datamash/datamash-1.3.ebuild b/sci-calculators/datamash/datamash-1.3.ebuild
new file mode 100644
index 000000000000..0a8743d8dd44
--- /dev/null
+++ b/sci-calculators/datamash/datamash-1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="command-line program for basic numeric, textual and statistical operations"
+HOMEPAGE="https://www.gnu.org/software/datamash/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls openssl"
+
+CDEPEND="
+ nls? ( sys-devel/gettext )
+ openssl? ( dev-libs/openssl )
+"
+RDEPEND="
+ nls? ( virtual/libintl )
+"
+DEPEND="
+ ${CDEPEND}
+ ${RDEPEND}
+"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(usex openssl --with-openssl={yes,no})
+}