summaryrefslogtreecommitdiff
path: root/sci-biology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-26 13:01:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-26 13:01:14 +0000
commite978c365080e8765f234868ad266cd333c53a94f (patch)
treeafd5bc811cabc934ef3382433ba23669cb62996c /sci-biology
parent3c68115c5485266603d1a893921971272f2be586 (diff)
gentoo auto-resync : 26:03:2024 - 13:01:14
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/Manifest.gzbin19338 -> 19345 bytes
-rw-r--r--sci-biology/bcftools/Manifest2
-rw-r--r--sci-biology/bcftools/bcftools-1.19.ebuild42
-rw-r--r--sci-biology/samtools/Manifest2
-rw-r--r--sci-biology/samtools/samtools-1.19.2.ebuild47
5 files changed, 93 insertions, 0 deletions
diff --git a/sci-biology/Manifest.gz b/sci-biology/Manifest.gz
index 1530474c3960..f7fec9ed238f 100644
--- a/sci-biology/Manifest.gz
+++ b/sci-biology/Manifest.gz
Binary files differ
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
index e67ac75194fe..9d0ed7aa0212 100644
--- a/sci-biology/bcftools/Manifest
+++ b/sci-biology/bcftools/Manifest
@@ -1,3 +1,5 @@
DIST bcftools-1.17.tar.bz2 7538043 BLAKE2B 82f65d53ebea0527ff000329f158ebdb1d603e04841a096cf8ca0434e7a5694ab43da7959ee10e9cb29328bf82301c03200e1203578a74e2e1118856b2641502 SHA512 39ae44a682e626a5261900e9412170a269e460b559d6607db697e6a12b1e512ffb3bdeb3486413e19b8adca26a8ccbb2bd4af24459decb74592c54473d2c6a68
+DIST bcftools-1.19.tar.bz2 7906216 BLAKE2B 43e7ac0fc6ffcf837607fb2fbbd58a72106a89b018d1fd4b24db0eb854a9bf0efd0c7762fae84bf7f51226346777be646d134159ea48e3eb3df71799e9353a3f SHA512 a203c65fa58fca8fb5276e73ed8fc23dfd841e9dc05881304a8b91327d60ac3b5fcf5a55a1f1bab5647037f037ff30f2881791052f6e29cf38c646cbc947a746
EBUILD bcftools-1.17.ebuild 900 BLAKE2B 98f04325ca039867010c25c5ebff64725de637960c1980cce0faee7b8514d187ca3a309a3db79bb809ebcb9938869884c89b54f232fcf826aa34b38c5dde9c6e SHA512 82bb9a379019f0d9f9c601fad06d4041e5b890cb21618cc37f37f5f6ce0c3d5d9cd1d6223a19b8a53303e8ab3ce4046a21fbd3b7b18fd45243d57226d040ffc4
+EBUILD bcftools-1.19.ebuild 901 BLAKE2B 401502d51a1b537d791355000f38403239ca57b41473cb58e1dcd3ab4057582fb19bec5d493df318386fe7c45337046e813a148d44ea0dda49468662d0567570 SHA512 b97efeaccdf86b37e714ff3f0e260f12927fa32eda3376b981d10ce7527b4da8f479e6b049386582e843329fa8e3d5a15236724e5a137d44219d1ebceca38097
MISC metadata.xml 344 BLAKE2B 37f8e82e8a5a9ad572580a7e5ae6daa6911d672f17b8526f81b236cbc2e50a32c4cd2566aaed9f5feee016d7e2de7db2a40b60616e86c3e8cae307d60cebc70e SHA512 0160c9606089d610613d71dc0aa9c9c5e5266483fdc9c407b6e0ed911eac8f8b32ffaf5a49bbb427393c8240e9868df51f0fc68b2f45467f65d9b3d54b0ddde1
diff --git a/sci-biology/bcftools/bcftools-1.19.ebuild b/sci-biology/bcftools/bcftools-1.19.ebuild
new file mode 100644
index 000000000000..27d474fe35f9
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.19.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ $(python_gen_cond_dep 'dev-python/matplotlib[${PYTHON_USEDEP}]')
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ python_fix_shebang misc/{gff2gff,guess-ploidy,plot-roh}.py
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --with-htslib=system
+}
diff --git a/sci-biology/samtools/Manifest b/sci-biology/samtools/Manifest
index d9bbfcc05f0a..add06bedafa2 100644
--- a/sci-biology/samtools/Manifest
+++ b/sci-biology/samtools/Manifest
@@ -1,3 +1,5 @@
DIST samtools-1.17.tar.bz2 8605080 BLAKE2B 09cb0bff7bf7113a77f57fdb879765b28b65461a574e4a1ab20ae2327af46e5616e04f03eb68706d42ba0643e887d7921974a3d78c5f87d296a4c3b691215260 SHA512 107a6df858c6bd2556ba4e86cc1922c3184df095f347039fa94bfd24e5ee21e1a4a9fba5a7cce248a06ad47f99978d9aae570efee7e30e165f33ea848a2cd3c3
+DIST samtools-1.19.2.tar.bz2 9150483 BLAKE2B fb845b2ccd61f1731ef4cdc180f4b9a4ac75e8c73c1ceaa9409b99e8052ca66b88c73fc71fd1067942aa24964f6df8dcb2d93631e5757e0cc200d7a3b9fad461 SHA512 c08d729fed21112855e0acc9cf7f29c7670d38a02ad6b0f2e9b9ef15a18f07e3e194cc4f6913481c98cd3e85dd4dc975dac96155b892da58bbe8ea3679a5270f
EBUILD samtools-1.17.ebuild 926 BLAKE2B c2baac0d68599fadfc1825e2c0046c0596d50cedd15e6859bbfffbd3d735ae6dca2e873d835120da7be8a9c91ce17dd449010dfa956899de69c807da0cc60c7c SHA512 d43c9a9da338c0820f0237925895684077a2df428be3892f3433f050c3082d605a1edefdb265ded6f123eed491dc05578d4e46177eb79d7fdad3eebc710e3764
+EBUILD samtools-1.19.2.ebuild 926 BLAKE2B a9acf64c51c87cf5d913982d22dba55901111ed1802f5795b0a1bd66979b600d815ee37c29aae83bc2d58c73a61330a4ada70fac4192022d23add1bdc89cf26c SHA512 ab73ecba708535299d9cbfc3c02a6efb292b9c85658247a7eba37b915776493027a2ca98de2e8bfe373a667119a06629a3a86f97eded244b7722887c685710c2
MISC metadata.xml 409 BLAKE2B c94eab9ebda4844beb471694106e353ccbbaca53e69de680301c6cfab3f3b6224ec94fcd631c9de2811d309463e5ee6decf2e443bfc68921f3362c6a312cd3af SHA512 fb2d3686e1ee70e4e80266a26603b3e52b680b1537a4569493a3a0511b93e2acdb2be3136df7ae54905a9f86fb7e53fa054607262751ebd8f54903f1905dad24
diff --git a/sci-biology/samtools/samtools-1.19.2.ebuild b/sci-biology/samtools/samtools-1.19.2.ebuild
new file mode 100644
index 000000000000..42879b0f8698
--- /dev/null
+++ b/sci-biology/samtools/samtools-1.19.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities for analysing and manipulating the SAM/BAM alignment formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-htslib=system \
+ CURSES_LIB="$($(tc-getPKG_CONFIG) --libs ncursesw || die)"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}