summaryrefslogtreecommitdiff
path: root/sci-biology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-21 14:46:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-21 14:46:21 +0100
commitd3f42b1ace45210af6c1b0c1970d626d411b15e0 (patch)
tree247085c9b7eb4f9b76c091d65482f26262c9b924 /sci-biology
parent7c334a9594ae315e537bf98259b95bafc60d479c (diff)
gentoo auto-resync : 21:07:2023 - 14:46:21
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/Manifest.gzbin19485 -> 19487 bytes
-rw-r--r--sci-biology/biopython/Manifest3
-rw-r--r--sci-biology/biopython/biopython-1.81-r1.ebuild59
-rw-r--r--sci-biology/biopython/files/biopython-1.81-python3.12.patch11
-rw-r--r--sci-biology/biopython/files/biopython-1.81-reportlab4.patch29
5 files changed, 102 insertions, 0 deletions
diff --git a/sci-biology/Manifest.gz b/sci-biology/Manifest.gz
index 3af3124bbc9c..779dd409d058 100644
--- a/sci-biology/Manifest.gz
+++ b/sci-biology/Manifest.gz
Binary files differ
diff --git a/sci-biology/biopython/Manifest b/sci-biology/biopython/Manifest
index c5cb8d233f06..3211736a9658 100644
--- a/sci-biology/biopython/Manifest
+++ b/sci-biology/biopython/Manifest
@@ -1,3 +1,6 @@
+AUX biopython-1.81-python3.12.patch 472 BLAKE2B 1c4b1c777e6bd7b80503b6a820caa9aad5601337a91c3275c3c7e97060a4f38deac9db77edb3d6ce76f3c20b883cc8c8301fe8cccba311c4280a99fc3264b8a4 SHA512 5e563b40e4278913a4f559b25e60b4b8909240fd367a66c1e43e1c525684482a928748838519a627bcc67c5c9bbd44537192bccf6813f8ee80bcc456af6d9bc9
+AUX biopython-1.81-reportlab4.patch 1068 BLAKE2B 1d2c2bf7929f5741f1bcae083d9842b16badba53f3be8fd3352b2b437a670b5032d146dc18610b7b360d503ad6613e9f0632457b8134392e8507900eff191526 SHA512 a576b12b8673471c27c8582f5ecb00ddf4b729a749af21a9ba67c6972dd5e9a535d7116b0ad7d06a5b89ff5b26d042914d23b1909b1081e1226df334e62d57f9
DIST biopython-1.81.tar.gz 19324875 BLAKE2B be3a85f5b60638987d6186af498411b494f8d27389f24cd1b9e658bc6b1a29c799ec8b20a9ac0b955c6d4c239706f4dbb5b75f6d56908f63d731b1d56c9fd587 SHA512 1595fad6631bfb6cf4e1a92ed72e6093e2a0c24f3c0bd4182267ec9742fb03dff16099eedde139598aa6b5b8380bbac9e48246cb9ab8b44109333d60adfd00ed
+EBUILD biopython-1.81-r1.ebuild 1621 BLAKE2B 4bfbb5ad817e10da15718f781aa2a0d6a9293739292ee3c228634fbb3e7df6e287018a00e6583c751e5d614f130c82ebc216ef7a5677688f66a6ae04c1f99070 SHA512 ea60a63b08a8345a2cf0b97d4a4ef9c4bdba9723d22e7875288406eee3494de4ce8fbedd626953773d71aeccfda625db4269236b325b5d372a7540fbc1f32f3a
EBUILD biopython-1.81.ebuild 1842 BLAKE2B 3037b2bd68de90c8d29911c36c82a9d0444fa4b0de4351d17ef261fbc652eba9f949562184b43556e8b9daf8f31c9e3def2af45f1f5355381bd75365c7a833bc SHA512 400ade4fe5e956a16ea939ba5d0f5bfcf6794cda64faeb181e1d8ca1c6ea99983fd89cc33e2d1998fd92da19083c0b9a8d83721af2cdc9f23950368f61a606e5
MISC metadata.xml 334 BLAKE2B 4d97c23444fdddcca57631fa2ddf4a11cfcef0accf91db65071d520f6601c0626e290e67cbf162abdefe7a74f4b410f8366a23186fc417e1fab7e9ce157d7610 SHA512 a870bd044d0e0d4e2a0c48b50f710845c6269e038790243f1d1de65b1252fd653f0f403fc55b98946df8eb27f24dfae5c84f52fcc38c969afcbdb548ccbb7a59
diff --git a/sci-biology/biopython/biopython-1.81-r1.ebuild b/sci-biology/biopython/biopython-1.81-r1.ebuild
new file mode 100644
index 000000000000..115a4d3b1a4c
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.81-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517="setuptools"
+DISTUTILS_EXT=1
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="https://www.biopython.org/ https://pypi.org/project/biopython/"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ >=dev-python/reportlab-3.5.13-r1[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/flex"
+
+DOCS=( {CONTRIB,DEPRECATED,NEWS,README}.rst Doc/. )
+
+PATCHES=(
+ "${FILESDIR}/${P}-reportlab4.patch"
+ "${FILESDIR}/${P}-python3.12.patch"
+)
+
+python_test() {
+ cd Tests || die
+ "${EPYTHON}" run_tests.py --offline --verbose || die
+}
+
+python_install_all() {
+ # remove files causing ecompressdir to fail
+ rm Doc/examples/ls_orchid.gbk.{gz,bz2} || die
+
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}
+
+pkg_postinst() {
+ optfeature_header "For database support you need to install:"
+ optfeature "MySQL database support" dev-python/mysqlclient
+ optfeature "PostgreSQL database support" dev-python/psycopg:2
+
+ optfeature_header "Some applications need extra packages:"
+ optfeature "EMBOSS (The European Molecular Biology Open Software Suite)" sci-biology/emboss
+}
diff --git a/sci-biology/biopython/files/biopython-1.81-python3.12.patch b/sci-biology/biopython/files/biopython-1.81-python3.12.patch
new file mode 100644
index 000000000000..8f903a4a39bd
--- /dev/null
+++ b/sci-biology/biopython/files/biopython-1.81-python3.12.patch
@@ -0,0 +1,11 @@
+--- a/Tests/test_Entrez.orig.py 2023-02-13 04:07:42.000000000 +0100
++++ b/Tests/test_Entrez.py 2023-06-30 14:42:58.177365639 +0200
+@@ -126,7 +126,7 @@
+ :type params: dict
+ :param expected: Expected set of IDs, as colleciton of strings.
+ """
+- testcase.assertEquals(len(params["id"]), 1)
++ testcase.assertEqual(len(params["id"]), 1)
+ ids_str = params["id"][0]
+ # Compare up to ordering
+ testcase.assertCountEqual(ids_str.split(","), expected)
diff --git a/sci-biology/biopython/files/biopython-1.81-reportlab4.patch b/sci-biology/biopython/files/biopython-1.81-reportlab4.patch
new file mode 100644
index 000000000000..ef1994553614
--- /dev/null
+++ b/sci-biology/biopython/files/biopython-1.81-reportlab4.patch
@@ -0,0 +1,29 @@
+From 74fdf49ade95157c3c4b23a95831925be4899223 Mon Sep 17 00:00:00 2001
+From: Peter Cock <p.j.a.cock@googlemail.com>
+Date: Mon, 5 Jun 2023 12:39:59 +0100
+Subject: [PATCH] Skip if ReportLab bitmap output module missing
+
+Would like to skip this earlier, but not so
+easy in ReportLab v4 with a choice of backends
+---
+ Tests/test_GraphicsBitmaps.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/Tests/test_GraphicsBitmaps.py b/Tests/test_GraphicsBitmaps.py
+index 2ffdfb3dd71..76615a2fd1d 100644
+--- a/Tests/test_GraphicsBitmaps.py
++++ b/Tests/test_GraphicsBitmaps.py
+@@ -111,9 +111,12 @@ def real_test():
+ "Check the fonts needed by ReportLab if you want "
+ "bitmaps from Bio.Graphics\n" + str(err)
+ ) from None
++ elif str(err).startswith("cannot import desired renderPM backend rlPyCairo"):
++ raise MissingExternalDependencyError(
++ "Reportlab module rlPyCairo unavailable\n" + str(err)
++ ) from None
+ else:
+ raise
+-
+ return True
+
+