summaryrefslogtreecommitdiff
path: root/sci-biology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-19 07:00:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-19 07:00:00 +0000
commitc5572b13d51970d6603acd131f27991cc1b66a79 (patch)
tree459c832fa5c0913b9ce0f85eed5e29922cc0425f /sci-biology
parent6e476156e1a0d2f4aa53968c37835c3441301367 (diff)
gentoo auto-resync : 19:11:2022 - 07:00:00
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/Manifest.gzbin20002 -> 20005 bytes
-rw-r--r--sci-biology/tree-puzzle/Manifest4
-rw-r--r--sci-biology/tree-puzzle/files/tree-puzzle-5.2-C99-decls.patch360
-rw-r--r--sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch14
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild9
5 files changed, 370 insertions, 17 deletions
diff --git a/sci-biology/Manifest.gz b/sci-biology/Manifest.gz
index 997e93a3aa25..797289a75e5b 100644
--- a/sci-biology/Manifest.gz
+++ b/sci-biology/Manifest.gz
Binary files differ
diff --git a/sci-biology/tree-puzzle/Manifest b/sci-biology/tree-puzzle/Manifest
index d13157e1d6c1..47a8f5a4de1c 100644
--- a/sci-biology/tree-puzzle/Manifest
+++ b/sci-biology/tree-puzzle/Manifest
@@ -1,5 +1,5 @@
+AUX tree-puzzle-5.2-C99-decls.patch 8138 BLAKE2B 94b8cc95f46d05b762e508ed7181a0c06fd05b98a06d1075d5e579cef6687bf7d617fe3ec69bf0cc57492079d628c7a636582efe00651deb44f7f9a976ea166b SHA512 30217da1f30615406d45795cda2d4a7210e2b845b54d1d05fd11bc403e02194767e11ec14eec9c0e44d9ebe0e5cbcefd1d12e71b1dcbd5a9588866b8ff2b51d9
AUX tree-puzzle-5.2-MPI-3.0.patch 15029 BLAKE2B 368eb7e3d209515a94f1049da80ebf9f14824e44e8c0b1996ba9c5ac7bfd58c167c01582bbc0d058a57d9797d844ad32e8bf45ce921a13c6e217d7728564a4d7 SHA512 576ed6c4a96225d55a1def0c4912cf908d0225d9ad9f9e0974a98f24d8bce172406a11202b9656c23661f6bb27b51a0b4e3bf95634b3c11aa10c20cd9d68e648
-AUX tree-puzzle-impl-dec.patch 380 BLAKE2B 22c00e2e0b4682a98212ec0b6e941ac37eff4cdeb8f684dc607e80a1617a35e209d23ac739af0e69af91deb8122fe04c3f9e7bdbd0c54edd8e603a817bdf0848 SHA512 092743fff8a305a41ef55afde3e058c1892d9c608bd05cb87de38a451c2b9cafc7749825347d5c245f1c6b1e84cf9d28b63bd4e7389440da5604766412290110
DIST tree-puzzle-5.2.tar.gz 875142 BLAKE2B aa13e9a7aa403c12aebefb94a1931baa8b17cbee56d20011cb06db5a7b1b7f78c719ed6c6bfb0b79e47dc652d7b984415694907fc6cd56bdbe9eebca4aaa96a8 SHA512 5b9a729b120cba59f59ba426acd439cf396826ea01e75361b23387ccb9baf295d2512f21af96071a5f7b7507db4ff4d6b135cf6c5b6233a8b438532d31abe751
-EBUILD tree-puzzle-5.2.ebuild 1097 BLAKE2B 3012cc63ec7ab38158729e754af531c5e09d11c993ae7abc9ba6d8be7aad98e800b3f9d442767afcb2fc4b71a0470698e68ebdf0eedc45435ba317801e36b932 SHA512 595de2081f21863d030382450d26a8677191b4e573258ef4ea185969df0b6a9868491c5c9b7d35517f8699ebcaa1e946b501622efbc1cccb3264c763c0c83f11
+EBUILD tree-puzzle-5.2.ebuild 1157 BLAKE2B e2c54db875cc4f107b57ef94956ebf2c572c9594851125cb60a886dc98856c8c8527b20b014e68aeec6b57ac7171794af3d6c049f133839e23bfcb3255112cd8 SHA512 a572c010039f119fb204430179ab153c14802d3fe0911f14b21f18eaed45bf1f3ccf51c5b20192cb84a68dd219477185d5970b1268cdf58cedb07ab90ad1bf93
MISC metadata.xml 1556 BLAKE2B 1f8b1d4719d156e9a9783adce70d8f4c0c17a7c855e5590bc796e16062066883a27f780946edaffdc04eb6f640ac7e81d71b075ebc5ed9759c2a5d4da20ac46e SHA512 07bd436f7616301172b07fefd72390a46778098baa3e9db949169850a60cd40e27a0e58dcafe5689923bc1e7cebb4e317a291f5caf2750651b76c447f5799215
diff --git a/sci-biology/tree-puzzle/files/tree-puzzle-5.2-C99-decls.patch b/sci-biology/tree-puzzle/files/tree-puzzle-5.2-C99-decls.patch
new file mode 100644
index 000000000000..98456c0dacc1
--- /dev/null
+++ b/sci-biology/tree-puzzle/files/tree-puzzle-5.2-C99-decls.patch
@@ -0,0 +1,360 @@
+--- a/src/consensus.c
++++ b/src/consensus.c
+@@ -32,7 +32,7 @@
+ /******************************************************************************/
+
+ /* prepare for consensus tree analysis */
+-void initconsensus()
++void initconsensus(void)
+ {
+ # if ! PARALLEL
+ biparts = new_cmatrix(Maxspc-3, Maxspc);
+--- a/src/consensus.h
++++ b/src/consensus.h
+@@ -65,7 +65,7 @@
+ /******************************************************************************/
+
+ /* prepare for consensus tree analysis */
+-void initconsensus();
++void initconsensus(void);
+
+ /* recursive function to get bipartitions */
+ /* traversal should be optimazable (HAS) */
+--- a/src/ml1.c
++++ b/src/ml1.c
+@@ -244,7 +244,7 @@
+ /***************************** exported functions *****************************/
+
+
+-void evaluateseqs()
++void evaluateseqs(void)
+ {
+ ivector ali;
+
+@@ -1018,7 +1018,7 @@
+
+
+ /* compute 1 PAM rate matrix, its eigensystem, and the inverse matrix thereof */
+-void tranprobmat()
++void tranprobmat(void)
+ {
+ eigensystem(Eval, Evec); /* eigensystem of 1 PAM rate matrix */
+ luinverse(Evec, Ievc, tpmradix); /* inverse eigenvectors are in Ievc */
+@@ -1324,7 +1324,7 @@
+
+
+ /* initialize distance matrix */
+-void initdistan()
++void initdistan(void)
+ {
+ int i, j, k, diff, x, y;
+ double obs, temp;
+@@ -1478,7 +1478,7 @@
+
+ #else /* not PARALLEL */
+
+-void computedistan()
++void computedistan(void)
+ {
+ int i, j;
+
+--- a/src/ml2.c
++++ b/src/ml2.c
+@@ -1036,7 +1036,7 @@
+
+
+ /* preparation for ML analysis */
+-void mlstart()
++void mlstart(void)
+ {
+ /* number of states and code length */
+ tpmradix = gettpmradix();
+@@ -1098,7 +1098,7 @@
+
+
+ /* cleanup after ML analysis */
+-void mlfinish()
++void mlfinish(void)
+ {
+ if (Ctree != NULL)
+ free_tree(Ctree, Numspc);
+@@ -1566,7 +1566,7 @@
+ int bestratefound,
+ int ncats) /* numcats */
+ #endif
+-void findbestratecombination()
++void findbestratecombination(void)
+ {
+ int k, u;
+ double bestvalue, fv2;
+@@ -2147,7 +2147,7 @@
+ } /* clock_lklhd */
+
+ /* find out the edge containing the root */
+-int findrootedge()
++int findrootedge(void)
+ {
+ int e, ebest;
+ double logbest, logtest;
+--- a/src/mlparam.c
++++ b/src/mlparam.c
+@@ -70,7 +70,7 @@
+ }
+
+ /* compute rates of each category when rates are Gamma-distributed */
+-void updaterates()
++void updaterates(void)
+ {
+ int i;
+ double alpha;
+@@ -190,7 +190,7 @@
+ }
+
+ /* estimate substitution process parameters - random quartets */
+-void optimseqevolparamsquart()
++void optimseqevolparamsquart(void)
+ {
+ double tsmeanold, yrmeanold;
+ dvector tslist, yrlist;
+@@ -320,7 +320,7 @@
+
+
+ /* optimize substitution process parameters - tree */
+-void optimseqevolparamstree()
++void optimseqevolparamstree(void)
+ {
+ twodimenmin(EPSILON_SUBSTPARAM,
+ (SH_optn || nuc_optn) && optim_optn && (data_optn == 0),
+@@ -379,7 +379,7 @@
+
+
+ /* optimize rate heterogeneity parameters */
+-void optimrateparams()
++void optimrateparams(void)
+ {
+ twodimenmin(EPSILON_RATEPARAM,
+ fracinv_optim,
+@@ -396,7 +396,7 @@
+
+ /* estimate parameters of substitution process and rate heterogeneity - no tree
+ n-taxon tree is not needed because of quartet method or NJ tree topology */
+-void estimateparametersnotree()
++void estimateparametersnotree(void)
+ {
+ int it, nump, change;
+ double TSold, YRold, FIold, GEold;
+@@ -495,7 +495,7 @@
+
+ /* estimate parameters of substitution process and rate heterogeneity - tree
+ same as above but here the n-taxon tree is already in memory */
+-void estimateparameterstree()
++void estimateparameterstree(void)
+ {
+ int it, nump, change;
+ double TSold, YRold, FIold, GEold;
+--- a/src/model1.c
++++ b/src/model1.c
+@@ -31,7 +31,7 @@
+ #include "ml.h"
+
+ /* number of states of the selected model */
+-int gettpmradix()
++int gettpmradix(void)
+ {
+ if (data_optn == 0) { /* nucleotides */
+ if (nuc_optn) return 4;
+--- a/src/puzzle1.c
++++ b/src/puzzle1.c
+@@ -345,7 +345,7 @@
+ /******************************************************************************/
+
+ /* compute TN parameters according to F84 Ts/Tv ratio */
+-void makeF84model()
++void makeF84model(void)
+ {
+ double rho, piA, piC, piG, piT, piR, piY, ts, yr;
+
+@@ -390,7 +390,7 @@
+ } /* makeF84model */
+
+ /* compute number of quartets used in LM analysis */
+-void compnumqts()
++void compnumqts(void)
+ {
+ if (lmqts == 0) {
+ if (numclust == 4)
+@@ -407,7 +407,7 @@
+ } /* compnumqts */
+
+ /* set options interactively */
+-void setoptions()
++void setoptions(void)
+ {
+ int i, valid;
+ double sumfreq;
+@@ -1718,7 +1718,7 @@
+ } /* closefile */
+
+ /* symmetrize doublet frequencies */
+-void symdoublets()
++void symdoublets(void)
+ {
+ int i, imean;
+ double mean;
+@@ -1769,7 +1769,7 @@
+ } /* symdoublets */
+
+ /* show Ts/Tv ratio and Ts Y/R ratio */
+-void computeexpectations()
++void computeexpectations(void)
+ {
+ double AlphaYBeta, AlphaRBeta, piR, piY, num, denom, pyr, pur;
+
+@@ -4604,7 +4604,7 @@
+ /* Reconstruct a tree with QP */
+ /* (parameter estimation already done) */
+
+-void recon_tree()
++void recon_tree(void)
+ {
+ int i;
+ unsigned char tmpweight;
+@@ -4848,7 +4848,7 @@
+
+ /***************************************************************/
+
+-void map_lklhd()
++void map_lklhd(void)
+ {
+ int i, a, a1, a2, b, b1, b2, c, c1, c2, d;
+ uli nq;
+@@ -5101,7 +5101,7 @@
+
+ /***************************************************************/
+
+-void setdefaults() {
++void setdefaults(void) {
+
+ strcpy(INFILE, INFILEDEFAULT);
+ strcpy(OUTFILE, OUTFILEDEFAULT);
+@@ -6027,7 +6027,7 @@
+
+ /***************************************************************/
+
+-void memcleanup() {
++void memcleanup(void) {
+ if (puzzlemode == QUARTPUZ && typ_optn == TREERECON_OPTN) {
+ free(splitfreqs);
+ free(splitpatterns);
+--- a/src/puzzle2.c
++++ b/src/puzzle2.c
+@@ -860,7 +860,7 @@
+
+
+ /* estimate mean base frequencies from translated data set */
+-void estimatebasefreqs()
++void estimatebasefreqs(void)
+ {
+ int tpmradix, i, j;
+ uli all, *gene;
+@@ -903,7 +903,7 @@
+
+
+ /* guess model of substitution */
+-void guessmodel()
++void guessmodel(void)
+ {
+ double c1, c2, c3, c4, c5, c6;
+ dvector f;
+@@ -1160,7 +1160,7 @@
+ } /* callocquartets */
+
+ /* free quartet memory */
+-void freequartets()
++void freequartets(void)
+ {
+ free(quartetinfo);
+ } /* freequartets */
+@@ -1357,7 +1357,7 @@
+ /*************************/
+
+ /* checks out all possible quartets */
+-void computeallquartets()
++void computeallquartets(void)
+ {
+ double onethird;
+ uli nq;
+--- a/src/sprng/makeseed.c
++++ b/src/sprng/makeseed.c
+@@ -1,10 +1,6 @@
+ #include <time.h>
+
+-#ifdef __STDC__
+-int make_new_seed()
+-#else
+-int make_new_seed()
+-#endif
++int make_new_seed(void)
+ {
+ time_t tp;
+ struct tm *temp;
+--- a/src/sprng/primes-lcg64.c
++++ b/src/sprng/primes-lcg64.c
+@@ -1,5 +1,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "primes-lcg64.h"
+ #include "primelist-lcg64.h"
+
+--- a/src/treesort.c
++++ b/src/treesort.c
+@@ -487,7 +487,7 @@
+ /**********/
+
+ /* malloc new tree list item */
+-treelistitemtype *gettreelistitem()
++treelistitemtype *gettreelistitem(void)
+ {
+ treelistitemtype *tmpptr;
+ tmpptr = (treelistitemtype *)calloc((size_t) 1, sizeof(treelistitemtype));
+--- a/src/treesort.h
++++ b/src/treesort.h
+@@ -84,7 +84,7 @@
+ /**********/
+
+ /* allocate memory for ctree 3 ints pointer plus 1 check byte */
+-int *initctree();
++int *initctree(void);
+
+ /**********/
+
+@@ -174,7 +174,7 @@
+ /**********/
+
+ /* malloc new tree list item */
+-treelistitemtype *gettreelistitem();
++treelistitemtype *gettreelistitem(void);
+
+ /**********/
+
+--- a/src/util.c
++++ b/src/util.c
+@@ -507,7 +507,7 @@
+ #define EPS 1.2e-7
+ #define RNMX (1.0-EPS)
+
+-double randomunitintervall()
++double randomunitintervall(void)
+ /* Long period (> 2e18) random number generator. Returns a uniform random
+ deviate between 0.0 and 1.0 (exclusive of endpoint values).
+
+@@ -734,7 +734,7 @@
+ /* Reads characters from stdin until a newline character or EOF
+ is received. The newline is not made part of the string.
+ If an error occurs a null string \0 is returned */
+-cvector mygets()
++cvector mygets(void)
+ {
+ int c, n;
+ cvector str;
diff --git a/sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch b/sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch
deleted file mode 100644
index 93b960f5c2b4..000000000000
--- a/sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch
+++ /dev/null
@@ -1,14 +0,0 @@
- src/sprng/primes-lcg64.c | 1 +
- 1 files changed, 1 insertions(+), 0 deletions(-)
-
-diff --git a/src/sprng/primes-lcg64.c b/src/sprng/primes-lcg64.c
-index 8e5a7c9..fb04373 100644
---- a/src/sprng/primes-lcg64.c
-+++ b/src/sprng/primes-lcg64.c
-@@ -1,5 +1,6 @@
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include "primes-lcg64.h"
- #include "primelist-lcg64.h"
-
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
index e5093420d6a8..b5e8e3931220 100644
--- a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data"
HOMEPAGE="http://www.tree-puzzle.de"
SRC_URI="http://www.tree-puzzle.de/${P}.tar.gz"
@@ -17,10 +19,15 @@ DEPEND="mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-impl-dec.patch
+ "${FILESDIR}"/${P}-C99-decls.patch
"${FILESDIR}"/${P}-MPI-3.0.patch
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
default