summaryrefslogtreecommitdiff
path: root/sci-biology/velvet/velvet-1.2.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-09 00:01:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-09 00:01:03 +0100
commita0ce545d52f231499bf9f3644493113d8af58ec9 (patch)
tree4d67c09eed0c2ae28d1317f72d7f7b08b4f6aeea /sci-biology/velvet/velvet-1.2.10.ebuild
parent5181ced3f3566a9610b85922b083c8f84f20d78f (diff)
gentoo auto-resync : 09:05:2024 - 00:01:03
Diffstat (limited to 'sci-biology/velvet/velvet-1.2.10.ebuild')
-rw-r--r--sci-biology/velvet/velvet-1.2.10.ebuild22
1 files changed, 20 insertions, 2 deletions
diff --git a/sci-biology/velvet/velvet-1.2.10.ebuild b/sci-biology/velvet/velvet-1.2.10.ebuild
index ea0b3630b78b..07b44eb65254 100644
--- a/sci-biology/velvet/velvet-1.2.10.ebuild
+++ b/sci-biology/velvet/velvet-1.2.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,7 +16,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc openmp"
-BDEPEND="doc? ( virtual/latex-base )"
+BDEPEND="
+ doc? ( virtual/latex-base )
+ openmp? (
+ || (
+ sys-devel/gcc[openmp]
+ sys-devel/clang-runtime[openmp]
+ )
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-incompatible-pointers.patch" )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
src_prepare() {
default