summaryrefslogtreecommitdiff
path: root/sci-biology/update-blastdb/update-blastdb-12.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/update-blastdb/update-blastdb-12.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/update-blastdb/update-blastdb-12.0.0.ebuild')
-rw-r--r--sci-biology/update-blastdb/update-blastdb-12.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-biology/update-blastdb/update-blastdb-12.0.0.ebuild b/sci-biology/update-blastdb/update-blastdb-12.0.0.ebuild
new file mode 100644
index 000000000000..e1524b487a03
--- /dev/null
+++ b/sci-biology/update-blastdb/update-blastdb-12.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit versionator
+
+MY_PV="$(replace_all_version_separators _)"
+
+DESCRIPTION="update_blastdb.pl for local blast db maintainance"
+HOMEPAGE="http://www.ncbi.nlm.nih.gov/books/bv.fcgi?rid=toolkit"
+SRC_URI="ftp://ftp.ncbi.nih.gov/toolbox/ncbi_tools++/ARCHIVE/${MY_PV}/ncbi_cxx--${MY_PV}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl
+ !sci-biology/ncbi-tools++"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ dobin ncbi_cxx--${MY_PV}/src/app/blast/update_blastdb.pl
+}