summaryrefslogtreecommitdiff
path: root/sci-biology/treeviewx/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/treeviewx/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/treeviewx/files')
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-70_choose_tree.patch12
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-fix_loading_crash.patch40
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch77
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-svg.patch30
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-treeview-xpm-not-xbm.patch16
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-wx30.patch78
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-wxstring-maxlen.patch34
-rw-r--r--sci-biology/treeviewx/files/treeviewx-wxt.patch50
8 files changed, 337 insertions, 0 deletions
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-70_choose_tree.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-70_choose_tree.patch
new file mode 100644
index 000000000000..ed5aa43e23c3
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-70_choose_tree.patch
@@ -0,0 +1,12 @@
+## 70_choose_tree.dpatch by William Alexander Grant <william.grant@ubuntu.com.au>
+--- tv-0.5.orig/tview.cpp
++++ tv-0.5/tview.cpp
+@@ -209,7 +209,7 @@
+ wxT("SVG vector picture files (*.svg)|*.svg"),
+ wxSAVE|wxOVERWRITE_PROMPT);
+
+- if (dialog.ShowModal() == wxID_OK)
++ if ((dialog.ShowModal() == wxID_OK) && (p.GetNumTrees() != 0))
+ {
+ wxSVGFileDC pictureDC (dialog.GetPath(), 600, 650) ;
+ OnDraw (&pictureDC);
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-fix_loading_crash.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-fix_loading_crash.patch
new file mode 100644
index 000000000000..c136539726a3
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-fix_loading_crash.patch
@@ -0,0 +1,40 @@
+Bug: http://code.google.com/p/treeviewx/issues/detail?id=1
+Description: fix crash on loading tree file.
+Author: Tim Booth
+--- tv-0.5.orig/tview.cpp
++++ tv-0.5/tview.cpp
+@@ -278,7 +278,7 @@
+ char buf[256];
+ strcpy (buf, p->GetLabel().c_str());
+ wchar_t wbuf[256];
+- mbstowcs (wbuf, buf, size_t(wbuf));
++ mbstowcs (wbuf, buf, 256);
+ s << wbuf;
+ #else
+ s << p->GetLabel().c_str();
+@@ -563,7 +563,7 @@
+ char buf[256];
+ strcpy (buf, t.GetName().c_str());
+ wchar_t wbuf[256];
+- mbstowcs (wbuf, buf, size_t(wbuf));
++ mbstowcs (wbuf, buf, 256);
+ txt << wbuf;
+ #else
+ txt << t.GetName().c_str();
+@@ -712,7 +712,7 @@
+ char buf[256];
+ strcpy (buf, p.GetIthTreeName(i).c_str());
+ wchar_t wbuf[256];
+- mbstowcs (wbuf, buf, size_t(wbuf));
++ mbstowcs (wbuf, buf, 256);
+
+ std::wstring tname = wbuf;
+
+@@ -1046,6 +1046,7 @@
+ void MyCanvas::OnSize(wxSizeEvent& event)
+ {
+ Resize ();
++ Refresh();
+ event.Skip();
+ }
+
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch
new file mode 100644
index 000000000000..33bd3b1741f6
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch
@@ -0,0 +1,77 @@
+diff -Naur tv-0.5.1/TreeLib/Parse.cpp tv-0.5.1.new/TreeLib/Parse.cpp
+--- tv-0.5.1/TreeLib/Parse.cpp 2002-02-23 07:22:32.000000000 -0500
++++ tv-0.5.1.new/TreeLib/Parse.cpp 2008-06-17 06:08:24.000000000 -0400
+@@ -24,6 +24,11 @@
+ #include <ctype.h>
+ #include "Parse.h"
+
++
++
++
++#include <cstring>
++
+ // Return the next token in the string
+ tokentype Parser::NextToken ()
+ {
+diff -Naur tv-0.5.1/TreeLib/TreeLib.cpp tv-0.5.1.new/TreeLib/TreeLib.cpp
+--- tv-0.5.1/TreeLib/TreeLib.cpp 2004-05-13 08:22:11.000000000 -0400
++++ tv-0.5.1.new/TreeLib/TreeLib.cpp 2008-06-17 05:58:17.000000000 -0400
+@@ -24,6 +24,8 @@
+ #include "TreeLib.h"
+ #include "Parse.h"
+
++
++#include <cstdlib>
+ #include <vector>
+
+
+diff -Naur tv-0.5.1/TreeLib/treereader.cpp tv-0.5.1.new/TreeLib/treereader.cpp
+--- tv-0.5.1/TreeLib/treereader.cpp 2003-09-10 08:58:16.000000000 -0400
++++ tv-0.5.1.new/TreeLib/treereader.cpp 2008-06-17 06:07:15.000000000 -0400
+@@ -28,6 +28,9 @@
+ #include <stdlib.h>
+ #endif
+
++#include <cstring>
++#include <cstdlib>
++
+ //------------------------------------------------------------------------------
+ TreeReader::TreeReader (Tokeniser &p) : parser (p)
+ {
+diff -Naur tv-0.5.1/ncl-2.0/src/charactersblock.cpp tv-0.5.1.new/ncl-2.0/src/charactersblock.cpp
+--- tv-0.5.1/ncl-2.0/src/charactersblock.cpp 2002-12-10 06:35:49.000000000 -0500
++++ tv-0.5.1.new/ncl-2.0/src/charactersblock.cpp 2008-06-17 05:58:17.000000000 -0400
+@@ -1,3 +1,5 @@
++
++#include <cstring>
+ #include "nexusdefs.h"
+ #include "xnexus.h"
+ #include "nexustoken.h"
+diff -Naur tv-0.5.1/ncl-2.0/src/nexus.cpp tv-0.5.1.new/ncl-2.0/src/nexus.cpp
+--- tv-0.5.1/ncl-2.0/src/nexus.cpp 2002-12-10 06:35:50.000000000 -0500
++++ tv-0.5.1.new/ncl-2.0/src/nexus.cpp 2008-06-17 05:58:17.000000000 -0400
+@@ -1,3 +1,5 @@
++
++#include <cstring>
+ #include "nexusdefs.h"
+ #include "xnexus.h"
+ #include "nexustoken.h"
+diff -Naur tv-0.5.1/ncl-2.0/src/nexustoken.cpp tv-0.5.1.new/ncl-2.0/src/nexustoken.cpp
+--- tv-0.5.1/ncl-2.0/src/nexustoken.cpp 2005-04-29 10:28:17.000000000 -0400
++++ tv-0.5.1.new/ncl-2.0/src/nexustoken.cpp 2008-06-17 05:58:17.000000000 -0400
+@@ -1,3 +1,5 @@
++
++#include <cstring>
+ #include "nexusdefs.h"
+ #include "xnexus.h"
+ #include "nexustoken.h"
+diff -Naur tv-0.5.1/ncl-2.0/src/nxsstring.cpp tv-0.5.1.new/ncl-2.0/src/nxsstring.cpp
+--- tv-0.5.1/ncl-2.0/src/nxsstring.cpp 2001-02-02 07:55:40.000000000 -0500
++++ tv-0.5.1.new/ncl-2.0/src/nxsstring.cpp 2008-06-17 05:58:17.000000000 -0400
+@@ -1,3 +1,6 @@
++
++#include <cstring>
++
+ #ifdef __BORLANDC__
+ // Undefine __MINMAX_DEFINED so that min and max are correctly defined
+ #ifdef __MINMAX_DEFINED
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-svg.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-svg.patch
new file mode 100644
index 000000000000..67a62179bb87
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-svg.patch
@@ -0,0 +1,30 @@
+Author: Olly Betts <olly@survex.com>
+Description: Update configure.in to match what it must have said when configure was generated.
+ One thing I should probably explain about the patch as my change may
+ seem odd otherwise - upstream's configure.in says "USE_SVG=0" but the
+ generated configure says "USE_SVG=1", so I've simply updated
+ configure.in to match what it must have said when configure was
+ generated.
+Forwarded: no
+--- tv-0.5.orig/configure.in
++++ tv-0.5/configure.in
+@@ -66,7 +66,9 @@
+ case "$wx_version" in
+ 2.4.*) WX_SVG_LIB=[`$WX_CONFIG --basename`_dcsvg-`echo ${wx_version} | sed -e "s:\.[0-9]\{1,\}$::"`]
+ ;;
+- *) WX_SVG_LIB=[`$WX_CONFIG --basename`_svg-`echo ${wx_version} | sed -e "s:\.[0-9]\{1,\}$::"`]
++ 2.*) WX_SVG_LIB=[`$WX_CONFIG --basename`_svg-`echo ${wx_version} | sed -e "s:\.[0-9]\{1,\}$::"`]
++ ;;
++ *) WX_SVG_LIB=
+ ;;
+ esac
+
+@@ -76,7 +78,7 @@
+
+ if test "$USE_SVG" = 1 ; then
+ CXXFLAGS="$CXXFLAGS -DUSE_SVG"
+- LIBS="$LIBS -l$WX_SVG_LIB"
++ test -n "$WX_SVG_LIB" && LIBS="$LIBS -l$WX_SVG_LIB"
+ fi
+
+ AC_OUTPUT(Makefile ncl-2.0/Makefile ncl-2.0/src/Makefile TreeLib/Makefile tv.spec)
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-treeview-xpm-not-xbm.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-treeview-xpm-not-xbm.patch
new file mode 100644
index 000000000000..a57ae19aaf26
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-treeview-xpm-not-xbm.patch
@@ -0,0 +1,16 @@
+Description: Fix the extension of the icon
+Author: Olly Betts <olly@survex.com>
+Last-Update: 2014-06-21
+Forwarded: http://code.google.com/p/treeviewx/issues/detail?id=4
+
+--- tv-0.5.orig/tv.cpp
++++ tv-0.5/tv.cpp
+@@ -215,7 +215,7 @@
+ frame->SetIcon(wxIcon("app")); // use the name of the icon in the resource file
+ #endif
+ #if defined(__WXGTK__) || defined(__WXMOTIF__)
+- frame->SetIcon(wxIcon(wxT("bitmaps/treeview.xbm")));
++ frame->SetIcon(wxIcon(wxT("/usr/share/pixmaps/treeviewx.xpm")));
+ #endif
+
+ #ifdef __WXMAC__
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-wx30.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-wx30.patch
new file mode 100644
index 000000000000..b1db5749990c
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-wx30.patch
@@ -0,0 +1,78 @@
+ tv.cpp | 4 ++--
+ tview.cpp | 12 ++++++++----
+ 2 files changed, 10 insertions(+), 6 deletions(-)
+
+diff --git a/tv.cpp b/tv.cpp
+old mode 100755
+new mode 100644
+index 1abe90b..0df45a8
+--- a/tv.cpp
++++ b/tv.cpp
+@@ -163,9 +163,9 @@ bool MyApp::OnInit(void)
+ {
+ // Optional command line argument is name of file to open
+ #if wxUSE_UNICODE
+- wchar_t *InputFile = NULL;
++ const wchar_t *InputFile = NULL;
+ #else
+- char *InputFile = NULL;
++ const char *InputFile = NULL;
+ #endif
+ // Read input/output files
+ if (argc > 1)
+diff --git a/tview.cpp b/tview.cpp
+old mode 100755
+new mode 100644
+index 93972c3..4b2d593
+--- a/tview.cpp
++++ b/tview.cpp
+@@ -62,9 +62,13 @@
+ #ifdef __WXMSW__
+ #else
+ #ifdef USE_SVG
++#if wxMAJOR_VERSION >= 3
++ #include <wx/dcsvg.h>
++#else
+ #include <wx/svg/dcsvg.h>
+ #endif
+ #endif
++#endif
+
+ // GUI interface
+ #include "tv.h"
+@@ -186,7 +190,7 @@ void TView::OnSavePicture (wxCommandEvent& WXUNUSED(event))
+ wxFrame *f = GetMainFrame();
+ wxFileDialog dialog((wxWindow *)f, wxT("Save Picture as"), wxT(""),
+ pictureFileName, wxT("Enhanced metafile (*.emf)|*.emf"),
+- wxSAVE|wxOVERWRITE_PROMPT);
++ wxFD_SAVE|wxFD_OVERWRITE_PROMPT);
+
+ if (dialog.ShowModal() == wxID_OK)
+ {
+@@ -206,7 +210,7 @@ void TView::OnSavePicture (wxCommandEvent& WXUNUSED(event))
+ #endif
+ wxFileDialog dialog((wxWindow *)f, wxT("Save Picture as"), wxT(""),
+ pictureFileName, wxT("SVG vector picture files (*.svg)|*.svg"),
+- wxSAVE|wxOVERWRITE_PROMPT);
++ wxFD_SAVE|wxFD_OVERWRITE_PROMPT);
+
+ if (dialog.ShowModal() == wxID_OK)
+ {
+@@ -361,7 +365,7 @@ bool TView::OnClose(bool deleteWindow)
+
+ // Clear the canvas in case we're in single-window mode,
+ // and the canvas stays.
+-#if (wxMINOR_VERSION > 4) // from 2.5 Clear is deprecated
++#if (wxMAJOR_VERSION >= 3 || wxMINOR_VERSION > 4) // from 2.5 Clear is deprecated
+ canvas->ClearBackground();
+ #else
+ canvas->Clear();
+@@ -686,7 +690,7 @@ void TView::OnLeafFont (wxCommandEvent& WXUNUSED(event))
+ wxFontData data;
+ data.SetInitialFont (LeafFont);
+
+-#ifdef __WXMAC__
++#if wxMAJOR_VERSION >= 3 || defined __WXMAC__
+ wxFontDialog dialog((wxWindow *)GetFrame(), data);
+ #else
+ wxFontDialog dialog((wxWindow *)GetMainFrame(), &data);
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-wxstring-maxlen.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-wxstring-maxlen.patch
new file mode 100644
index 000000000000..2c5179f778ca
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-wxstring-maxlen.patch
@@ -0,0 +1,34 @@
+Description: Remove wxSTRING_MAXLEN (removed in wx3.0) and incomp. definition.
+ The definition wxSTRING_MAXLEN was removed from the public API of wxWidgets.
+ Its meaning was basically "take all the string", whenever a string length was
+ expected. The missing definition didn't raise a compilation error because
+ TreeLib's treedrawer.h contained a fall-back definition, which is however
+ incompatible with the original definition of wxWidgets and therefore is
+ interpreted by wxWidgets as a number representing the real string length.
+ This patch gets rid of the dangerous fall-back definition and of all of its
+ uses by using alternative wxString constructors that achieve the same
+ behavior.
+Author: Martin Steghöfer <martin@steghoefer.eu>
+Last-Update: Sun, 10 Aug 2014 14:06:42 +0200
+Bug-Debian: http://bugs.debian.org/751255
+
+--- tv-0.5.orig/TreeLib/treedrawer.cpp
++++ tv-0.5/TreeLib/treedrawer.cpp
+@@ -245,7 +245,7 @@
+ // error in gcc, which is probably a gcc bug
+ {
+ wxCoord w, h, descent;
+- wxString s (formatedString.c_str(), wxSTRING_MAXLEN);
++ wxString s (formatedString.c_str());
+ pt.x += dc->GetCharWidth();
+ pt.y -= dc->GetCharHeight()/2;
+ dc->DrawText (s, (int)pt.x, (int)pt.y);
+@@ -566,7 +566,7 @@
+
+ #if USE_WXWINDOWS
+ wxCoord w, h;
+- wxString s (buf, wxSTRING_MAXLEN);
++ wxString s (buf);
+ dc->GetTextExtent (s, &w, &h);
+ int x = (int)pt2.x;
+ int y = (int)pt2.y;
diff --git a/sci-biology/treeviewx/files/treeviewx-wxt.patch b/sci-biology/treeviewx/files/treeviewx-wxt.patch
new file mode 100644
index 000000000000..b1c03bbb39f9
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-wxt.patch
@@ -0,0 +1,50 @@
+--- tv.cpp~ 2005-10-01 16:47:35.000000000 -0400
++++ tv.cpp 2005-10-01 16:52:30.000000000 -0400
+@@ -312,11 +312,15 @@
+ {
+ #ifdef __WXMSW__
+ file_menu->AppendSeparator();
+- file_menu->Append(SAVEAS_PICTURE_CMD, "Save As Picture..."), wxT("Save picture of tree to metafile");
++ file_menu->Append(SAVEAS_PICTURE_CMD,
++ wxT("Save As Picture...")),
++ wxT("Save picture of tree to metafile");
+ #else
+ #ifdef USE_SVG
+ file_menu->AppendSeparator();
+- file_menu->Append(SAVEAS_PICTURE_CMD, "Save As Picture..."), wxT("Save picture of tree to SVG file");
++ file_menu->Append(SAVEAS_PICTURE_CMD,
++ wxT("Save As Picture...")),
++ wxT("Save picture of tree to SVG file");
+ #endif
+ #endif
+ file_menu->AppendSeparator();
+--- tview.cpp~ 2005-10-01 16:47:45.000000000 -0400
++++ tview.cpp 2005-10-01 16:50:42.000000000 -0400
+@@ -184,10 +184,10 @@
+ wxString pictureFileName = GetFrame()->GetTitle();
+ pictureFileName += wxT(".emf");
+ wxFrame *f = GetMainFrame();
+- wxFileDialog dialog((wxWindow *)f, "Save Picture as", "", pictureFileName,
+- "Enhanced metafile (*.emf)|*.emf",
+- wxSAVE|wxOVERWRITE_PROMPT);
+-
++ wxFileDialog dialog((wxWindow *)f, wxT("Save Picture as"), wxT(""),
++ pictureFileName, wxT("Enhanced metafile (*.emf)|*.emf"),
++ wxSAVE|wxOVERWRITE_PROMPT);
++
+ if (dialog.ShowModal() == wxID_OK)
+ {
+ wxMetafileDC pictureDC (dialog.GetPath(), 600, 650) ;
+@@ -204,9 +204,9 @@
+ #else
+ wxFrame *f = GetMainFrame();
+ #endif
+- wxFileDialog dialog((wxWindow *)f, "Save Picture as", "", pictureFileName,
+- "SVG vector picture files (*.svg)|*.svg",
+- wxSAVE|wxOVERWRITE_PROMPT);
++ wxFileDialog dialog((wxWindow *)f, wxT("Save Picture as"), wxT(""),
++ pictureFileName, wxT("SVG vector picture files (*.svg)|*.svg"),
++ wxSAVE|wxOVERWRITE_PROMPT);
+
+ if (dialog.ShowModal() == wxID_OK)
+ {