summaryrefslogtreecommitdiff
path: root/sci-biology/snpfile/snpfile-2.0.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/snpfile/snpfile-2.0.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/snpfile/snpfile-2.0.1-r2.ebuild')
-rw-r--r--sci-biology/snpfile/snpfile-2.0.1-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-biology/snpfile/snpfile-2.0.1-r2.ebuild b/sci-biology/snpfile/snpfile-2.0.1-r2.ebuild
new file mode 100644
index 000000000000..bbeb3111901f
--- /dev/null
+++ b/sci-biology/snpfile/snpfile-2.0.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A library and API for manipulating large SNP datasets"
+HOMEPAGE="http://www.birc.au.dk/~mailund/SNPFile/"
+SRC_URI="http://www.birc.au.dk/~mailund/SNPFile/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="static-libs"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/boost:="
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/autoconf-archive-2016.09.16"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc44.patch
+ "${FILESDIR}"/${P}-gentoo.diff
+ "${FILESDIR}"/${P}-gold.patch
+ "${FILESDIR}"/${P}-ax-boost.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ rm m4/ax_boost.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}