summaryrefslogtreecommitdiff
path: root/sci-biology/rnaview/rnaview-20040713-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /sci-biology/rnaview/rnaview-20040713-r5.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'sci-biology/rnaview/rnaview-20040713-r5.ebuild')
-rw-r--r--sci-biology/rnaview/rnaview-20040713-r5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-biology/rnaview/rnaview-20040713-r5.ebuild b/sci-biology/rnaview/rnaview-20040713-r5.ebuild
new file mode 100644
index 000000000000..c0c4289ba24b
--- /dev/null
+++ b/sci-biology/rnaview/rnaview-20040713-r5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Generates 2D displays of RNA/DNA secondary structures with tertiary interactions"
+HOMEPAGE="http://ndbserver.rutgers.edu/services/download/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-implicit.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ default
+
+ newenvd - 22rnaview <<- EOF
+ RNAVIEW="${EPREFIX}/usr/share/rnaview"
+ EOF
+}