summaryrefslogtreecommitdiff
path: root/sci-biology/recon/recon-1.08.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/recon/recon-1.08.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/recon/recon-1.08.ebuild')
-rw-r--r--sci-biology/recon/recon-1.08.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-biology/recon/recon-1.08.ebuild b/sci-biology/recon/recon-1.08.ebuild
new file mode 100644
index 000000000000..a96403c812be
--- /dev/null
+++ b/sci-biology/recon/recon-1.08.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automated de novo identification of repeat families from genomic sequences"
+HOMEPAGE="http://www.repeatmasker.org/RepeatModeler.html"
+SRC_URI="http://www.repeatmasker.org/${P^^}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${P^^}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.08-buffer-overflow.patch
+ "${FILESDIR}"/${PN}-1.08-perl-shebangs.patch
+)
+
+src_prepare() {
+ default
+ sed -i "s|$path = \"\";|$path = \"${EPREFIX}/usr/libexec/${PN}\";|" scripts/recon.pl || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" -C src
+}
+
+src_install() {
+ dobin scripts/*
+
+ exeinto /usr/libexec/${PN}
+ doexe src/{edgeredef,eledef,eleredef,famdef,imagespread}
+
+ newdoc {00,}README
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r Demos
+ fi
+}