summaryrefslogtreecommitdiff
path: root/sci-biology/poa/poa-2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/poa/poa-2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/poa/poa-2-r1.ebuild')
-rw-r--r--sci-biology/poa/poa-2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-biology/poa/poa-2-r1.ebuild b/sci-biology/poa/poa-2-r1.ebuild
new file mode 100644
index 000000000000..c53fcd5f5f24
--- /dev/null
+++ b/sci-biology/poa/poa-2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${PN}V${PV}"
+
+DESCRIPTION="Fast multiple sequence alignments using partial-order graphs"
+HOMEPAGE="http://bioinfo.mbi.ucla.edu/poa/"
+SRC_URI="mirror://sourceforge/poamsa/${MY_P}.tar.gz"
+
+# According to SF project page
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="static-libs"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-respect-flags.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ OPT_CFLAGS="${CFLAGS}" \
+ poa
+}
+
+src_install() {
+ dobin "${S}"/poa "${S}"/make_pscores.pl
+ use static-libs && dolib.a "${S}"/liblpo.a
+ dodoc "${S}"/README "${S}"/multidom.*
+ insinto /usr/share/poa
+ doins "${S}"/*.mat
+}
+
+pkg_postinst() {
+ elog "poa requires a score matrix as the first argument."
+ elog "This package installs two examples to ${EROOT}usr/share/poa/."
+}