summaryrefslogtreecommitdiff
path: root/sci-biology/phylip/phylip-3.696-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/phylip/phylip-3.696-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/phylip/phylip-3.696-r1.ebuild')
-rw-r--r--sci-biology/phylip/phylip-3.696-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-biology/phylip/phylip-3.696-r1.ebuild b/sci-biology/phylip/phylip-3.696-r1.ebuild
new file mode 100644
index 000000000000..03b33b303805
--- /dev/null
+++ b/sci-biology/phylip/phylip-3.696-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION=" The PHYLogeny Inference Package"
+HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
+SRC_URI="http://evolution.gs.washington.edu/${PN}/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ mv Makefile.unx Makefile || die
+ sed \
+ -e "/ -o /s:\(\$(CC)\):\1 ${LDFLAGS}:g" \
+ -i Makefile || die "Patching Makefile failed."
+ mkdir ../fonts || die
+}
+
+src_compile() {
+ emake -j1 \
+ CC="$(tc-getCC)" \
+ DC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wno-unused-result" \
+ all put
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}" || die
+
+ mv exe/font* fonts || die "Font move failed."
+ mv exe/factor exe/factor-${PN} || die "Renaming factor failed."
+
+ dolib.so exe/*so && rm exe/*so || die
+ dobin exe/*
+
+ dodoc "${FILESDIR}"/README.Gentoo
+
+ dohtml -r phylip.html doc
+
+ insinto /usr/share/${PN}/
+ doins -r fonts
+}