summaryrefslogtreecommitdiff
path: root/sci-biology/mira/mira-4.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/mira/mira-4.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/mira/mira-4.0.2.ebuild')
-rw-r--r--sci-biology/mira/mira-4.0.2.ebuild97
1 files changed, 97 insertions, 0 deletions
diff --git a/sci-biology/mira/mira-4.0.2.ebuild b/sci-biology/mira/mira-4.0.2.ebuild
new file mode 100644
index 000000000000..fd95fbfb2a78
--- /dev/null
+++ b/sci-biology/mira/mira-4.0.2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MIRA_3RDPARTY_PV="06-07-2012"
+MY_PV="${PV/_}" # convert from mira-4.0_rc2 (Gentoo ebuild filename derived) to mira-4.0rc2 (upstream fromat)
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Whole Genome Shotgun and EST Sequence Assembler for Sanger, 454 and Illumina"
+HOMEPAGE="http://www.chevreux.org/projects_mira.html"
+SRC_URI="
+ https://sourceforge.net/projects/mira-assembler/files/MIRA/stable/"${PN}"-"${MY_PV}".tar.bz2
+ mirror://sourceforge/mira-assembler/mira_3rdparty_${MIRA_3RDPARTY_PV}.tar.bz2"
+# https://sourceforge.net/projects/mira-assembler/files/MIRA/development/${P}.tar.bz2
+# mirror://sourceforge/mira-assembler/mira_3rdparty_${MIRA_3RDPARTY_PV}.tar.bz2"
+
+S="${WORKDIR}"/"${PN}"-"${MY_PV}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+CDEPEND="
+ dev-libs/boost[threads]
+ dev-util/google-perftools"
+DEPEND="${CDEPEND}
+ sys-devel/flex
+ app-editors/vim-core
+ dev-libs/expat"
+RDEPEND="${CDEPEND}"
+
+#DOCS=( AUTHORS GETTING_STARTED NEWS README HELP_WANTED
+# THANKS doc/3rdparty/scaffolding_MIRA_BAMBUS.pdf )
+DOCS=( AUTHORS GETTING_STARTED NEWS README HELP_WANTED THANKS )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.2-boost-1.50.patch"
+ "${FILESDIR}/${PN}-4.0.2-cout.patch"
+ "${FILESDIR}/${PN}-4.0.2-cmath.patch"
+)
+
+src_prepare() {
+ find -name 'configure*' -or -name 'Makefile*' | xargs sed -i 's/flex++/flex -+/' || die
+
+ default
+
+ sed \
+ -e "s:-O[23]::g" \
+ -e "s:-funroll-loops::g" \
+ -i configure.ac || die
+
+ eautoreconf
+
+ # Remove C++ source files that upstream built with flex.
+ local f
+ local PREBUILT_CXX_LEXER_FILES=(
+ "${S}"/src/caf/caf_flexer.cc
+ "${S}"/src/io/exp_flexer.cc
+ "${S}"/src/mira/parameters_flexer.cc
+ )
+
+ for f in "${PREBUILT_CXX_LEXER_FILES[@]}"; do
+ if [[ -f ${f} ]] ; then
+ rm "${f}" || die "Failed to remove ${f}"
+ else
+ die "${f} not found"
+ fi
+ done
+}
+
+src_configure() {
+ econf \
+ --with-boost="${EPREFIX}/usr/$(get_libdir)" \
+ --with-boost-libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-boost-thread=boost_thread-mt
+}
+
+#src_compile() {
+# base_src_compile
+# # TODO: resolve docbook incompatibility for building docs
+# if use doc; then emake -C doc clean docs || die; fi
+#}
+
+src_install() {
+ default
+
+ dobin "${WORKDIR}"/3rdparty/{sff_extract,qual2ball,*.pl}
+ dodoc "${WORKDIR}"/3rdparty/{README.txt,midi_screen.fasta}
+}
+
+pkg_postinst() {
+ einfo "Documentation is no longer built, you can find it at:"
+ einfo "http://mira-assembler.sourceforge.net/docs/DefinitiveGuideToMIRA.html"
+}