summaryrefslogtreecommitdiff
path: root/sci-biology/infernal/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/infernal/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/infernal/files')
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-ldflags.patch15
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-overflows.patch15
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch31
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-perl-5.16-2.patch147
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch16
5 files changed, 224 insertions, 0 deletions
diff --git a/sci-biology/infernal/files/infernal-1.0.2-ldflags.patch b/sci-biology/infernal/files/infernal-1.0.2-ldflags.patch
new file mode 100644
index 000000000000..f688dce152ed
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-ldflags.patch
@@ -0,0 +1,15 @@
+Respect LDFLAGS
+
+http://bugs.gentoo.org/show_bug.cgi?id=338177
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -86,7 +86,7 @@
+ all: $(PROGS)
+
+ $(PROGS): @EXEC_DEPENDENCY@ $(OBJS) ${HDRS}
+- $(CC) $(CFLAGS) $(DEFS) $(MYLIBDIR) -o $@ $@.o $(OBJS) $(MYLIBS) $(LIBS) $(MPILIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(DEFS) $(MYLIBDIR) -o $@ $@.o $(OBJS) $(MYLIBS) $(LIBS) $(MPILIBS)
+
+
+ #################################################################
diff --git a/sci-biology/infernal/files/infernal-1.0.2-overflows.patch b/sci-biology/infernal/files/infernal-1.0.2-overflows.patch
new file mode 100644
index 000000000000..67190c4c1d42
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-overflows.patch
@@ -0,0 +1,15 @@
+Fix buffer overflow
+
+http://bugs.gentoo.org/show_bug.cgi?id=338179
+
+--- a/easel/esl_getopts.c
++++ b/easel/esl_getopts.c
+@@ -1270,7 +1270,7 @@
+ "Arg looks like option? Use %.24s%.24s if you really mean it.",
+ g->opt[opti].name, *ret_optarg);
+ } else
+- ESL_FAIL(eslESYNTAX, "Option %.24s requires an argument", g->opt[opti].name);
++ ESL_FAIL(eslESYNTAX, g->errbuf, "Option %.24s requires an argument", g->opt[opti].name);
+
+ g->optstring = NULL; /* An optchar that takes an arg must terminate an optstring. */
+ }
diff --git a/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch b/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch
new file mode 100644
index 000000000000..67ffa6fda7f6
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch
@@ -0,0 +1,31 @@
+Fix parallel build
+
+http://bugs.gentoo.org/show_bug.cgi?id=311919
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -82,9 +82,10 @@
+ all: core
+
+ core:
+- (cd easel; make CC="$(CC)" CFLAGS="$(CFLAGS)"; make)
+- (cd src; make CC="$(CC)" CFLAGS="$(CFLAGS)"; make module)
+- (cd testsuite; make CC="$(CC)" CFLAGS="$(CFLAGS)")
++ $(MAKE) -C easel
++ $(MAKE) -C src
++ $(MAKE) -C src module
++ $(MAKE) -C testsuite
+
+ #.PHONY: $(RIGFILTERS)
+ #$(RIGFILTERS): core
+--- a/easel/Makefile.in
++++ b/easel/Makefile.in
+@@ -132,7 +132,7 @@
+ esl_wuss.o
+
+ all: libeasel.a
+- (cd miniapps; make)
++ $(MAKE) -C miniapps
+
+ .c.o:
+ ${CC} -I. ${CFLAGS} ${SIMDFLAGS} ${DEFS} -c $<
diff --git a/sci-biology/infernal/files/infernal-1.0.2-perl-5.16-2.patch b/sci-biology/infernal/files/infernal-1.0.2-perl-5.16-2.patch
new file mode 100644
index 000000000000..c96dcae7b296
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-perl-5.16-2.patch
@@ -0,0 +1,147 @@
+ benchmarks/cmsearch-rmark/sre.pl | 4 +---
+ easel/devkit/autodoc | 4 ++--
+ easel/devkit/esl-dependencies | 4 ++--
+ easel/devkit/sqc | 7 +++----
+ easel/testsuite/coverage_report.pl | 4 ++--
+ easel/testsuite/driver_report.pl | 4 ++--
+ easel/testsuite/valgrind_report.pl | 4 ++--
+ 7 files changed, 14 insertions(+), 17 deletions(-)
+
+diff --git a/benchmarks/cmsearch-rmark/sre.pl b/benchmarks/cmsearch-rmark/sre.pl
+index 9136717..e4df233 100644
+--- a/benchmarks/cmsearch-rmark/sre.pl
++++ b/benchmarks/cmsearch-rmark/sre.pl
+@@ -6,8 +6,6 @@
+
+ package SRE_perlstuff;
+
+-require "importenv.pl";
+-
+ # Function: tempname
+ #
+ # Returns a unique temporary filename.
+@@ -26,7 +24,7 @@ require "importenv.pl";
+ #
+ sub main'tempname {
+ local ($dir, $name);
+- if ($TMPDIR) { $dir = $TMPDIR; } else {$dir = "/tmp";}
++ if ($ENV{TMPDIR}) { $dir = $ENV{TMPDIR}; } else {$dir = "/tmp";}
+
+ foreach $suffix ("aa".."zz") {
+ $name = "$dir/sre$suffix$$";
+diff --git a/easel/devkit/autodoc b/easel/devkit/autodoc
+old mode 100755
+new mode 100644
+index 045ce36..22268f6
+--- a/easel/devkit/autodoc
++++ b/easel/devkit/autodoc
+@@ -49,8 +49,8 @@
+ #
+ # SRE, Tue Nov 30 19:43:47 2004
+
+-require "getopts.pl";
+-&Getopts('n:t');
++use Getopt::Std;
++getopts('n:t');
+ $cfile = shift;
+
+ if ($opt_t) { $show_api_table = 1; }
+diff --git a/easel/devkit/esl-dependencies b/easel/devkit/esl-dependencies
+old mode 100755
+new mode 100644
+index a4dc126..b61fa7a
+--- a/easel/devkit/esl-dependencies
++++ b/easel/devkit/esl-dependencies
+@@ -13,8 +13,8 @@
+ # SRE, Mon Jun 11 11:15:31 2007
+ # SVN $Id$
+
+-require "getopts.pl"
+-&Getopts('1afr');
++use Getopt::Std;
++getopts('1afr');
+
+ if ($opt_1) { $show_summary_table = 1; }
+ if ($opt_a) { $list_augfiles = 1; }
+diff --git a/easel/devkit/sqc b/easel/devkit/sqc
+old mode 100755
+new mode 100644
+index 81d03de..6201d3d
+--- a/easel/devkit/sqc
++++ b/easel/devkit/sqc
+@@ -176,12 +176,11 @@
+ # SRE, Tue Aug 6 11:16:39 2002
+ # SVN $Id: sqc 1796 2007-01-03 22:36:44Z eddys $
+
+-require "getopts.pl";
+-require "importenv.pl";
++use Getopt::Std;
+
+ # Parse our command line
+ #
+-&Getopts('mp:r:v');
++getopts('mp:r:v');
+ if ($opt_m) { $do_memtest = 1; }
+ if ($opt_p) { push @prepdirs, $opt_p; }
+ if ($opt_r) { push @olddirs, $opt_r; }
+@@ -510,7 +509,7 @@ check_ccmalloc_status
+ #
+ sub tempname {
+ my ($dir, $name, $suffix);
+- if ($TMPDIR) { $dir = $TMPDIR."/"; } else {$dir = "";}
++ if ($ENV{TMPDIR}) { $dir = $ENV{TMPDIR}."/"; } else {$dir = "";}
+
+ foreach $suffix ("aa".."zz") {
+ $name = "$dir"."esltmp".$suffix.$$;
+diff --git a/easel/testsuite/coverage_report.pl b/easel/testsuite/coverage_report.pl
+old mode 100755
+new mode 100644
+index 9c77791..024ed34
+--- a/easel/testsuite/coverage_report.pl
++++ b/easel/testsuite/coverage_report.pl
+@@ -16,9 +16,9 @@
+ #
+ # SRE, Thu Mar 1 19:22:57 2007 (Janelia)
+ # SVN $Id: coverage_report.pl 231 2008-03-25 14:43:57Z eddys $
+-require "getopts.pl";
++use Getopt::Std;
+ $have_sloccount = 1;
+-&Getopts('cs');
++getopts('cs');
+ if ($opt_c) { $do_recompile = 1; }
+ if ($opt_s) { $have_sloccount = 0; }
+
+diff --git a/easel/testsuite/driver_report.pl b/easel/testsuite/driver_report.pl
+old mode 100755
+new mode 100644
+index d1b4a9a..db4378f
+--- a/easel/testsuite/driver_report.pl
++++ b/easel/testsuite/driver_report.pl
+@@ -19,8 +19,8 @@
+ # SRE, Fri Mar 2 10:01:44 2007 (Janelia)
+ # SVN $Id: driver_report.pl 231 2008-03-25 14:43:57Z eddys $
+
+-require "getopts.pl";
+-&Getopts('c');
++use Getopt::Std;
++getopts('c');
+ if ($opt_c) { $do_recompile = 1; }
+
+ if ($ENV{'CC'} ne "") { $CC = $ENV{'CC'}; } else { $CC = "gcc"; }
+diff --git a/easel/testsuite/valgrind_report.pl b/easel/testsuite/valgrind_report.pl
+old mode 100755
+new mode 100644
+index 186a392..07026a0
+--- a/easel/testsuite/valgrind_report.pl
++++ b/easel/testsuite/valgrind_report.pl
+@@ -10,8 +10,8 @@
+ #
+ # SRE, Fri Mar 2 08:37:48 2007 [Janelia]
+ # SVN $Id: valgrind_report.pl 231 2008-03-25 14:43:57Z eddys $
+-require "getopts.pl";
+-&Getopts('c');
++use Getopt::Std;
++getopts('c');
+ if ($opt_c) { $do_recompile = 1; }
+
+ if ($ENV{'CC'} ne "") { $CC = $ENV{'CC'}; } else { $CC = "gcc"; }
diff --git a/sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch b/sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch
new file mode 100644
index 000000000000..ea465e592ffa
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch
@@ -0,0 +1,16 @@
+Build system does not respect DESTDIR by default.
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -203,9 +203,9 @@
+ # "make install" installs the programs in BINDIR
+ #
+ install:
+- mkdir -p ${BINDIR}
++ mkdir -p $(DESTDIR)${BINDIR}
+ for file in $(PROGS); do\
+- cp src/$$file $(BINDIR)/;\
++ cp src/$$file $(DESTDIR)$(BINDIR)/;\
+ done
+ # if test -d $(RIGFILTERS); then\
+ # for file in $(RFPROGS); do\