summaryrefslogtreecommitdiff
path: root/sci-biology/gibbs/gibbs-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sci-biology/gibbs/gibbs-3.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sci-biology/gibbs/gibbs-3.1.ebuild')
-rw-r--r--sci-biology/gibbs/gibbs-3.1.ebuild34
1 files changed, 16 insertions, 18 deletions
diff --git a/sci-biology/gibbs/gibbs-3.1.ebuild b/sci-biology/gibbs/gibbs-3.1.ebuild
index de8322a5068e..a06d0880ee4d 100644
--- a/sci-biology/gibbs/gibbs-3.1.ebuild
+++ b/sci-biology/gibbs/gibbs-3.1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils multilib
+inherit autotools
DESCRIPTION="Identify motifs, conserved regions, in DNA or protein sequences"
HOMEPAGE="http://bayesweb.wadsworth.org/gibbs/gibbs.html"
@@ -13,37 +11,37 @@ SRC_URI="mirror://gentoo/gibbs-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-IUSE="mpi"
KEYWORDS="amd64 x86"
+IUSE="mpi"
DEPEND="
mpi? (
virtual/mpi
- sys-cluster/mpe2 )"
+ sys-cluster/mpe2
+ )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${PN}-3.1-fix-CFLAGS.patch )
+
src_prepare() {
- sed \
- -e 's/CFLAGS="$OPTFLAGS/CFLAGS="$CFLAGS $OPTFLAGS/' \
- -e 's/-Werror//' \
- -i configure.in || die
- autotools-utils_src_prepare
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_configure() {
- if use mpi; then export CC=mpicc; fi
- local myeconfargs=( $(use_enable mpi) )
- autotools-utils_src_configure
+ use mpi && export CC=mpicc
+ econf $(use_enable mpi)
}
src_install() {
- autotools-utils_src_install
+ default
+
exeinto /usr/$(get_libdir)/${PN}
doexe *.pl
- dodoc README ChangeLog
}
pkg_postinst() {
- einfo "Supplementary Perl scripts for Gibbs have been installed into /usr/$(get_libdir)/${PN}."
+ einfo "Supplementary Perl scripts for Gibbs have been installed into ${EROOT}/usr/$(get_libdir)/${PN}."
einfo "These scripts require installation of sci-biology/bioperl."
}