summaryrefslogtreecommitdiff
path: root/sci-biology/express/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/express/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/express/files')
-rw-r--r--sci-biology/express/files/express-1.5.1-buildsystem.patch55
-rw-r--r--sci-biology/express/files/express-1.5.1-gcc6.patch19
2 files changed, 74 insertions, 0 deletions
diff --git a/sci-biology/express/files/express-1.5.1-buildsystem.patch b/sci-biology/express/files/express-1.5.1-buildsystem.patch
new file mode 100644
index 000000000000..fca5feadd111
--- /dev/null
+++ b/sci-biology/express/files/express-1.5.1-buildsystem.patch
@@ -0,0 +1,55 @@
+ CMakeLists.txt | 8 +++-----
+ src/CMakeLists.txt | 4 ++--
+ 2 files changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c768e28..65d5633 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,14 +6,12 @@ set(${PROJECT_NAME}_VERSION_MAJOR 1)
+ set(${PROJECT_NAME}_VERSION_MINOR 5)
+ set(${PROJECT_NAME}_VERSION_PATCH 1)
+
+-set(CMAKE_CXX_FLAGS "-Wall")
+-
+ set(CMAKE_CXX_FLAGS_DEBUG "-g ${CMAKE_CXX_FLAGS}")
+ set(CMAKE_CXX_FLAGS_RHDEBINFO "-O3 -g ${CMAKE_CXX_FLAGS}")
+ set(CMAKE_CXX_FLAGS_MINSIZEREL "-Os ${CMAKE_CXX_FLAGS}")
+
+ set(CMAKE_BUILD_TYPE Release)
+-set(Boost_USE_STATIC_LIBS ON)
++set(Boost_USE_STATIC_LIBS OFF)
+
+ find_package(Boost 1.39
+ COMPONENTS
+@@ -33,10 +31,10 @@ endif(GPERFTOOLS_TCMALLOC_LIB)
+
+ find_package(Protobuf)
+ if (PROTOBUF_FOUND)
+- include_directories(${Boost_INCLUDE_DIRS} ${PROTOBUF_INCLUDE_DIR} "${CMAKE_CURRENT_SOURCE_DIR}/bamtools/include")
++ include_directories(${Boost_INCLUDE_DIRS} ${PROTOBUF_INCLUDE_DIR} ${BAMTOOLS_INCLUDE})
+ set(PROTO_INT 1)
+ else (PROTOBUF_FOUND)
+- include_directories(${Boost_INCLUDE_DIRS} "${CMAKE_CURRENT_SOURCE_DIR}/bamtools/include")
++ include_directories(${Boost_INCLUDE_DIRS} ${BAMTOOLS_INCLUDE})
+ set(PROTO_INT 0)
+ endif(PROTOBUF_FOUND)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 1cc0c01..8929d1f 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -16,11 +16,11 @@ endif (GPERFTOOLS_TCMALLOC)
+ if(WIN32)
+ set(LIBRARIES ${LIBRARIES} "${CMAKE_CURRENT_SOURCE_DIR}/../bamtools/lib/libbamtools.lib" "${CMAKE_CURRENT_SOURCE_DIR}/../win_build/zlibd.lib")
+ else(WIN32)
+- set(LIBRARIES ${LIBRARIES} "${CMAKE_CURRENT_SOURCE_DIR}/../bamtools/lib/libbamtools.a" "pthread")
++ set(LIBRARIES ${LIBRARIES} "bamtools" "pthread")
+ endif(WIN32)
+
+ if (PROTOBUF_FOUND)
+- set(LIBRARIES ${LIBRARIES} "libprotobuf.a")
++ set(LIBRARIES ${LIBRARIES} "protobuf")
+ endif(PROTOBUF_FOUND)
+
+ target_link_libraries(express ${LIBRARIES})
diff --git a/sci-biology/express/files/express-1.5.1-gcc6.patch b/sci-biology/express/files/express-1.5.1-gcc6.patch
new file mode 100644
index 000000000000..8a608b97b056
--- /dev/null
+++ b/sci-biology/express/files/express-1.5.1-gcc6.patch
@@ -0,0 +1,19 @@
+Bug: https://bugs.gentoo.org/610692
+
+--- a/src/targets.cpp
++++ b/src/targets.cpp
+@@ -113,12 +113,12 @@
+
+ double ll = LOG_1;
+ double tot_mass = mass(with_pseudo);
+- double tot_eff_len = cached_effective_length(lib.bias_table);
++ double tot_eff_len = cached_effective_length(static_cast<bool>(lib.bias_table));
+ if (neighbors) {
+ foreach (const Target* neighbor, *neighbors) {
+ tot_mass = log_add(tot_mass, neighbor->mass(with_pseudo));
+ tot_eff_len = log_add(tot_eff_len,
+- neighbor->cached_effective_length(lib.bias_table));
++ neighbor->cached_effective_length(static_cast<bool>(lib.bias_table)));
+ }
+ }
+ ll += tot_mass - tot_eff_len;