summaryrefslogtreecommitdiff
path: root/sci-biology/embassy-hmmer/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/embassy-hmmer/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/embassy-hmmer/files')
-rw-r--r--sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.650_fix-build-system.patch100
-rw-r--r--sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.660-slotted-hmmer2.patch101
2 files changed, 201 insertions, 0 deletions
diff --git a/sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.650_fix-build-system.patch b/sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.650_fix-build-system.patch
new file mode 100644
index 000000000000..90c45632eada
--- /dev/null
+++ b/sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.650_fix-build-system.patch
@@ -0,0 +1,100 @@
+ configure.ac | 49 +++++++------------------------------------------
+ src/Makefile.am | 6 ++----
+ 2 files changed, 9 insertions(+), 46 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 037ca00..f539ab6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -635,33 +635,6 @@ AS_CASE([${host_os}],
+
+
+
+-dnl PCRE library definitions - see the MAJOR and MINOR values
+-dnl to see which version's configure.in these lines come from
+-
+-dnl Provide the current PCRE version information. Do not use numbers
+-dnl with leading zeros for the minor version, as they end up in a C
+-dnl macro, and may be treated as octal constants. Stick to single
+-dnl digits for minor numbers less than 10. There are unlikely to be
+-dnl that many releases anyway.
+-
+-PCRE_MAJOR="7"
+-PCRE_MINOR="9"
+-PCRE_DATE="11-Apr-2009"
+-PCRE_VERSION="${PCRE_MAJOR}.${PCRE_MINOR}"
+-
+-dnl Default values for miscellaneous macros
+-
+-POSIX_MALLOC_THRESHOLD="-DPOSIX_MALLOC_THRESHOLD=10"
+-
+-dnl Provide versioning information for libtool shared libraries that
+-dnl are built by default on Unix systems.
+-
+-PCRE_LIB_VERSION="0:1:0"
+-PCRE_POSIXLIB_VERSION="0:0:0"
+-
+-
+-
+-
+ dnl FIXME: This does no longer seem required with Autoconf 2.67?
+ dnl Intel MacOSX 10.6 puts X11 in a non-standard place
+ dnl AS_IF([test "x${with_x}" != "xno"],
+@@ -737,21 +710,6 @@ AX_LIB_POSTGRESQL
+
+
+
+-dnl "Export" these variables for PCRE
+-
+-AC_SUBST([HAVE_MEMMOVE])
+-AC_SUBST([HAVE_STRERROR])
+-AC_SUBST([PCRE_MAJOR])
+-AC_SUBST([PCRE_MINOR])
+-AC_SUBST([PCRE_DATE])
+-AC_SUBST([PCRE_VERSION])
+-AC_SUBST([PCRE_LIB_VERSION])
+-AC_SUBST([PCRE_POSIXLIB_VERSION])
+-AC_SUBST([POSIX_MALLOC_THRESHOLD])
+-
+-
+-
+-
+ dnl Test if --enable-localforce given
+ locallink="no"
+ embprefix="/usr/local"
+@@ -874,6 +832,13 @@ AC_ARG_ENABLE([systemlibs],
+ AM_CONDITIONAL([ESYSTEMLIBS], [test "x${enable_systemlibs}" = "xyes"])
+
+
++AS_IF([test "x${enable_systemlibs}" = "xyes"],
++[
++dnl using system libraries
++ PKG_CHECK_MODULES([PLPLOT], [plplotd],
++ [],[PKG_CHECK_MODULES([PLPLOT], [plplot])]
++ )
++])
+
+
+ # Enable the purify tool: --enable-purify, sets CC and LIBTOOL
+diff --git a/src/Makefile.am b/src/Makefile.am
+index dc789bc..5a8c38e 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -17,9 +17,7 @@ AM_CPPFLAGS = -I../../../nucleus -I../../../ajax/pcre \
+ -I../../../ajax/ensembl -I../../../ajax/ajaxdb \
+ -I../../../ajax/acd -I../../../plplot
+ else
+-AM_CPPFLAGS = -I${embprefix}/include -I${embprefix}/include/eplplot \
+- $(NLINCLUDES) \
+- -I${embprefix}/include/epcre
++AM_CPPFLAGS = -I${embprefix}/include $(NLINCLUDES) $(PLPLOT_CFLAGS)
+ endif
+
+ if ISSHARED
+@@ -67,5 +65,5 @@ LDADD = ../../../nucleus/libnucleus.la ../../../ajax/acd/libacd.la \
+ $(XLIB)
+ else
+ LDADD = -L${embprefix}/lib -lnucleus -lacd -lajaxdb -lensembl -lajaxg \
+- -lajax -lepcre $(NLADD) -leplplot $(XLIB)
++ -lajax $(NLADD) $(XLIB)
+ endif
diff --git a/sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.660-slotted-hmmer2.patch b/sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.660-slotted-hmmer2.patch
new file mode 100644
index 000000000000..f202ddf3d0b5
--- /dev/null
+++ b/sci-biology/embassy-hmmer/files/embassy-hmmer-2.3.2.660-slotted-hmmer2.patch
@@ -0,0 +1,101 @@
+Amend command-line names for Gentoo SLOTed hmmer:2
+
+--- a/src/ehmmalign.c
++++ b/src/ehmmalign.c
+@@ -99,7 +99,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajFmtPrintS(&cmd, "%S ", ajAcdGetpathC("hmmalign"));
++ ajFmtPrintS(&cmd, "%S ", ajAcdGetpathC("hmmalign2"));
+ if(mapali)
+ ajFmtPrintAppS(&cmd, " --mapali %s ", ajFileGetNameC(mapali));
+ if(withali)
+--- a/src/ehmmbuild.c
++++ b/src/ehmmbuild.c
+@@ -146,7 +146,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmbuild"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmbuild2"));
+ if(prior)
+ ajFmtPrintAppS(&cmd, " --prior %s ", ajFileGetNameC(prior));
+ if(null)
+--- a/src/ehmmcalibrate.c
++++ b/src/ehmmcalibrate.c
+@@ -98,7 +98,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmcalibrate"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmcalibrate2"));
+ if(cpu)
+ ajFmtPrintAppS(&cmd, " --cpu %d ", cpu);
+ if(fixed)
+--- a/src/ehmmconvert.c
++++ b/src/ehmmconvert.c
+@@ -72,7 +72,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmconvert"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmconvert2"));
+
+ /* ACD option only allows one selection */
+ option = ajStrGetCharFirst(format);
+--- a/src/ehmmemit.c
++++ b/src/ehmmemit.c
+@@ -79,7 +79,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmemit"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmemit2"));
+ ajFmtPrintAppS(&cmd, " --seed %d ", seed);
+ if(a)
+ ajStrAppendC(&cmd, " -a ");
+--- a/src/ehmmfetch.c
++++ b/src/ehmmfetch.c
+@@ -74,7 +74,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmfetch"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmfetch2"));
+ if(nhmm)
+ ajStrAppendC(&cmd, " -n ");
+ /* Note the output redirected to outfname */
+--- a/src/ehmmindex.c
++++ b/src/ehmmindex.c
+@@ -68,7 +68,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajFmtPrintS(&cmd, "%S ", ajAcdGetpathC("hmmindex"));
++ ajFmtPrintS(&cmd, "%S ", ajAcdGetpathC("hmmindex2"));
+ ajStrAppendC(&cmd, ajFileGetNameC(database));
+
+
+--- a/src/ehmmpfam.c
++++ b/src/ehmmpfam.c
+@@ -122,7 +122,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmpfam"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmpfam2"));
+ if(nuc)
+ ajStrAppendC(&cmd, " -n ");
+ ajFmtPrintAppS(&cmd, " -A %d -E %f -T %f -Z %d", A, E, T, Z);
+--- a/src/ehmmsearch.c
++++ b/src/ehmmsearch.c
+@@ -102,7 +102,7 @@
+ iii.HMMER 'options' (that don't appear in ACD file)
+ iv. HMMER & new parameters.
+ */
+- ajStrAssignS(&cmd, ajAcdGetpathC("hmmsearch"));
++ ajStrAssignS(&cmd, ajAcdGetpathC("hmmsearch2"));
+ ajFmtPrintAppS(&cmd, " -A %d -E %f -T %f -Z %d", A, E, T, Z);
+ if(compat)
+ ajStrAppendC(&cmd, " --compat ");